Due to the U.S. Thanksgiving holiday, please expect delayed responses during the week of 11/22.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Target error when debugging with FR5969LP

Other Parts Discussed in Thread: MSP430FR5738, MSP430FR5734, MSP430FR5969, MSP-EXP430FR5969, MSP-EXP430FR5739

I am trying to debug an external FR5738 connected to an FR5969LP via the .05"  jumper header to the EZ430 emulator on board.  This has worked fine on other launchpads, and it is able to program and debug a separate G2332 just fine.  However, when I try to program the FR5738, it says 

"Error connecting to the target:
The target setup (MSP430FR5738) does not match the actual target type (MSP430FR5734)"

Now I am definitely using an FR5738.  I tried making a new project, reloading the linker command file, rebuilding the target config, etc, and none of that worked.  I was able to successfully program the chip by changing the target config and linker command file to the FR5734, which is what it appears to think the target is.  This solution is not satisfactory, however, because the 5734 has half the program memory of the 5738.  

Any thoughts on a way to fix this?  

Thanks!

Brody G

  • Hi Brody,

    Sorry to hear of your troubles. Using the configuration where you were able to connect to the device, can you please try reading out the Device ID info found at addresses 0x1A04-5 in the device? If you see www.ti.com/.../msp430fr5738 you'll see in Table 8-1 and 8-2 that the data stored in the device at these addresses should indicate what device variant is being used. I'd like to check this to make sure it matches the value for FR5738 vs FR5738. You should be able to do this simply in CCS by opening the Memory view while you are in debug mode, and pull up the address 0x1A04. Can you share what you read back?

    Can you also share:
    1. What connections you have made from the MSP430FR5969 eZ-FET to the pins on the MSP430FR5738 board, including any passives on any of the lines? How are the boards being powered when programming (is the FR5738 powered from the eZ-Fet Vcc as recommended)
    2. What version of CCS you are using?
    3. What revision information is listed on your MSP-EXP430FR5969LP board (should have a board Rev listed somewhere on the board)?

    Regards,
    Katie
  • Thanks Katie,

    I now have a full MSP-FET430UIF that is able to program the device, but I still want to figure out why the launchpad is unable to do so.  That portion of memory (0x1A04) seems to be overwritten each time the device is programmed because when I program my board (the FR5738) with the launchpad (as an FR5734, again since that is the only way it works), that memory location reads 0x00.  The table you linked indicates that this means it is an FR5734.  When I program it as a 5738 with the full FET, it correctly reads 0x02.  

    I am using CCS 6.1, the latest release.  

    I have tried using 2 launchpads, both of which are the MSP-EXP430FR5969.    One is Rev 1.6, the other is Rev 2.0.  Both have the same result.

    The target board has been in development for a while now; previously we succesfully used an MSP-EXP430FR5739 LP to program it.  The RST line has a 47K ohm pullup resistor connected to VCC and a 2200pF cap to ground.  It is connected via a 1.27mm header to the launchpad.  This header on the launchpad is on the other side of the isolation block from the EZ-FET emulator (different from other launchpads I have experience with), so the isolation block jumpers are in place.  The only way I could find to isolate the target board from the launchpad processor was to disconnect the J9 jumper, labeled "current."  

    Thanks again!

    Brody

  • Hi Brody,

    Those addresses (0x1A04 etc) in the TLV structure are actually not able to be written - they are written once at production and are not able to be written even by the device itself after. Therefore, since you read the correct values with the MSP-FET430UIF, it seems that what is happening is that the MSP-EXP430FR5969 Launchpad is not reading this area of memory correctly for some reason.

    I am concerned that you have some signals still connected to the MSP430FR5969 device on the Launchpad - even without Vcc connected, the MSP can power up off of signals on other lines (like TEST/RST) so I wonder if it could be interfering with the communication. Could you try using wires to connect directly to the pins on the eZ-FET side of the jumper block instead, so that you can remove those jumpers and for sure only have your target MSP connected to the eZ-FET? I will also see if I can reproduce here.

    Regards,
    Katie
  • Okay,
    It worked when I disconnected all of the jumpers on the block and only connected Vcc, GND, RST, and TST to my target board. Is there not a built in way to use J21 (1.27mm header) on this launchpad?
    Thanks,
    Brody
  • Hi Brody,

    Looking in the Launchpad user's guide www.ti.com/.../slau535 section 2.3.6 Using the eZ-FET Emulator with a Different Target, it says that you should use wires going from the eZ-FET side to your target device, with the jumpers pulled off. So basically what you have done now. For J21, based on how it is on the target device side of the isolation jumper block, I think J21 must be there as another way to program the MSP-EXP430FR5969 rather than being a way to program a different chip off of the board. I don't think you'll be able to use it unless you never want to use the MSP-EXP430FR5969 Launchpad to program the on-board FR5969 and decide to cut traces to "hack" this in, but I think it would be less drastic to just wire up to the eZ-FET side of the isolation block.

    Regards,
    Katie