This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Using a MSP-TS430PM64 and getting " Error connecting to target -Unknown Device"

Other Parts Discussed in Thread: MSP-TS430PM64, MSP-FET430UIF, MSP-GANG

Configuration: Windows 10---CCS 6.1---MSP-FETU430IF---MSP-TS430PM64---MSP430F233. Removed jumper J7 and voltage was 0.6V.

Just received the PM64, plugged the 14 pin JTAG in, put the F233 chip in with dot on pin 1 and tried to run a debug. Please tell me what I need to do to flash a load and burn the fuse. Should I be using something other than CCS 6.1? 

  • If you removed J7, then how is your chip getting VCC voltage?
  • Hi Jerry,

    As Brian mentioned, without J7 there will not be power being provided to VCC on the MSP430, so you won't be able to program the part. You will want to have J7 connected, make sure that R8 is populated (not R9) and connect the programmer to the 14-pin JTAG header. With this, you should be able to program the device. If you still have problems with J7 in place, let us know if there is a particular error message you are getting when you try to program - the error message can also be helpful for debugging the issue.

    (NOTE: if you want to see the schematic of the MSP-TS430PM64 board, see www.ti.com/lit/pdf/slau278 )

    Regards,
    Katie

  • Of course, I put the R7 jumper back on. Only removed it according to the instructions to measure voltage. Voltage read 0.6

    After trying to do a "Clean" followed by "Debug" over 15 times it started working about one out of every three attempts.

    When it worked and loaded the chip, I selected "Load" which worked followed by a "Verify" which worked. 

    I believe the problem is my MSP-FETU430IF is old and providing a weak current.. That is why it works sometimes and not every time, I think.

    Now, would someone tell me how to command CCS 6.1 to blow the fuse. According to the literature that takes 3.3V on a specific pin.

  • One other question. Is the .out file suitable for a production load where the chip is to be put onto a PCB to be used in a finished product?
  • Kate, the error received is "Error connecting to the target: Unknown device"
  • Jerry,

    I'm concerned that you are having so much trouble getting the device to program - what error messages is it giving when it fails? Are you trying to connect and program in a binary or .out file, rather than just clicking the "bug" on a CCS project to build and load the code?

    Note that another piece of software you can use with the MSP-FET430UIF is the Elprotronic Fet-Pro430 Lite software www.elprotronic.com/productdata

    In CCSv6.1 per www.ti.com/.../slau157 section E.1.3 you can blow the fuse while in a debugging section by going to Run > Advanced > Make Device Secure. However, if you really do have some connection problem I'd be a little bit concerned about this really working correctly. Note that once you do this you will be permanently locked out of the device, so you'll want to ensure you have the correct code loaded before you do it. You can also use the other software mentioned above for blowing the fuse.

    CCS is not usually used for production programming - are you just using this for testing? Or are you looking for a long term production programming solution?

    Regards,
    Katie
  • Looks like you replied while I was typing.

    An unknown device error does seem like it would indicate that there is a bit of a connection issue here. Do you have anything else on the target board, or just the MSP in the socket, not connected to anything else? Was the MSP-TS430PM64 board one that you just received unaltered, or had someone else used it before? (just checking for modifications etc)? Is there a Rev. number on the MSP-TS430PM64 board, silkscreened somewhere?

    For .out file - usually when people do production programming, they use something besides CCS. In general, I've seen people generate a TI-txt file or Intel hex file (both types of binary files) and use that with a tool like the MSP-GANG for production programming. The MSP-GANG can program 8 devices at once and programs a lot faster than the MSP-FET430UIF.
    processors.wiki.ti.com/.../Generating_and_Loading_MSP430_Binary_Files
    www.ti.com/.../msp-gang

    Regards,
    Katie
  • Katie,
    Deeply appreciate your time and effort in trying to help. You gave excellent answers. However, it is hard to believe what happened. When I received the new MSP-TS430PM64, I plugged my 15 year old MSP-FETU430IF into the JTAG, put chips into the socket and tried to load them. The first 20-25 times they all gave the error "Error connecting to target Unknown Device". Then,about one out of five worked. Soon one out of 3 worked, Then, they all started working. Programmed and blew fuse on over 70 chips with no problem. My theory, for what it is worth, is there was oil or something preventing one or more of the 64 legs on the chip making good contact in the socket.
    Thanks again. Without your help, I do not think I would have tried so many times to solve the problem, resulting in no solution.
  • Hi Jerry,

    Wow, that is definitely an unusual case, and unfortunate that it took you so much manual work to get it up and going. If you start having troubles again please let us know!

    -Katie

**Attention** This is a public forum