This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Debugging MSP430F5232 with ez430-EMULATION board is possible?

Other Parts Discussed in Thread: MSP430F5232, MSP-EXP430F5529, CC430F5137, MSP-EXP430F5529LP, MSP-EXP430FR5969, MSP-EXP430FR4133, MSP-EXP430FR6989, MSP-EXP430FR5994, MSP-FET, MSP430F5529, MSP430F5528

Hello, guys.

I have a circuit based on a MSP430F5232 and I am trying to program/debug it drawing the MSP-EXP430F5529 board that we already had using the part eZ430-EMULATION [image attached]. We are using the platform CCS v6, and the firmware is a simple LED BLINK.

We used this sort of programming with CC430F5137 without any problem, but with the microcontroller MSP430F5232 it always appears the message "Could not find device (or device not supported)". The lines connected between MSP430F5232 and the eZ430 Target connector are: VCC, GND, RSTDVCC/SBWTDIO and TEST/SBWTCK.

I have used the Vcc of the ez430-emulation without powering the PCB and the own Vcc of the PCB, disconnecting the line VCC with ez. But in both cases it didn't program.

Could it be the RST/NMI pin the problem. I just connected it to a pullup resistor (47K)? The line RSTDVV/SBWTDIO has a pullup resistor of 47K: could it be the problem?

What am I doing wrong?

Thanks in advance!

Best regards, 

Luis

  • Hi Luis!

    The MSP-EXP430F5529 you are using does officially not support your target processor:

    If you had the MSP-EXP430F5529LP (or another LaunchPad with eZ-FET or eZ-FET Lite) instead, you could program all MSP devices.

    Dennis

  • Thank you Dennis for your quick response.
    So, reading your reply, the part eZ430-EMULATION of the board MSP-EXP430F5529 doesn't work with the family MSP430F52xx/MSP430F54xx, no?

    So, which low cost programmer/debugger could be used with the MSP430F5232?

    Thanks again, Dennis!
  • luis.lopez said:
    the part eZ430-EMULATION of the board MSP-EXP430F5529 doesn't work with the family MSP430F52xx/MSP430F54xx

    It is at least not officially supported, so it will most probably not work.

    luis.lopez said:
    So, which low cost programmer/debugger could be used

    You can use every LaunchPad that has an eZ-FET or eZ-FET Lite emulation IP. Here are some:

    • MSP-EXP430F5529LP
    • MSP-EXP430FR5969
    • MSP-EXP430FR4133
    • MSP-EXP430FR6989
    • MSP-EXP430FR5994

    Or the programming tool MSP-FET.

    Dennis

  • Thank you very much, Dennis.
  • luis.lopez said:

    "Could not find device (or device not supported)".

    I don't know how many years TI needs to split this error it two, where everything will be crystal clear:

    Error1: Could not find device on SBW / JTAG bus.

    Error2: Device (JTAG ID) is present on JTAG bus, but it is not supported.

    luis.lopez said:

    Could it be the RST/NMI pin the problem. I just connected it to a pullup resistor (47K)? The line RSTDVV/SBWTDIO has a pullup resistor of 47K: could it be the problem?

    What am I doing wrong?

    No, RST is not the problem because 5xx devices have internal pull up, and 1nF or 2.2nF capacitor on RST pin is just disturbing factor for SBW. You are not doing anything wrong. Try same setup with msp-debug and you will see.

  • Luis,

    eZ FET Lite (that can debug / program all TI SBW devices) is based on MSP430F5528, that is the same chip (except layout) as MSP430F5529. So if you want, and there is no any conflict connection on your EXP board, you can use it as base for eZ FET Lite. Just take care that during eZ FET Lite upload, to not blow JTAG fuse that is located inside BSL flash area.

    http://forum.43oh.com/topic/5530-custom-ezfet-lite/