This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/MSP430FR5889: Using Capacitive touch IO feature.

Part Number: MSP430FR5889

Tool/software: Code Composer Studio

Dear Team,

Our current project includes the requirement for using capacitive touch IO feature of this microcontroller. When we went through the user guide and user specific data sheet of this microcontroller we found that there is very limited description on the application of this. User guide says output can be observed in timer and described in device specific data sheet , but there is no explicit description of capactive input for timer in device specific data sheet of MSP430FR5889.  On further observation in device specific data sheet we found Timer A2 and Timer A3 mentions about capactive touch input, But If we use this as capture input what is the INCLK frequency ? Can we have an application note for this usage. I tried reading many but none of those speaks about usage of inbuilt capacitive touch io module. Kindly help us.

  • Hello Vijeth,

    The MSP430FR5889 has capacitive touch capable I/Os. We have examples if how to use and enable this feature, along with the SW required within MSP430Ware. To use this functionality, two timers are required. Typically one instance of TA/B and the RTC or WDT. Please see the associated User Guide for the library for its usage and which examples are made for your device.

    Within the TI Resource Explorer (found in CCS or dev.ti.com) navigate to Software -> MSP430Ware -> Libraries -> Capacitive Touch Software Library
  • Dear Jace,

    As per the suggestion provided by you, we have tried using the example library code provided in slac489 library. We are using Code Composer 6 version. The only change we made in this library is the microcontroller . We are using MSP430FR5889. After loading the example code to our module , When we checked the capactive IO registers in debugger mode ,  RO_CSIO_TA2_WDTA_One_Button.rarit is still 0x00. Why it is not getting updated with this given configuration. In the example project it is configured for P1.5 . Still it is not getting updated . Please find the screen shot and example code attached here.  

  • Hello Vijeth,

    The example within the library uses LPM3. As the Warning on the console has stated, the EEM cannot accurately access the device when in this state. This means the register view does not accurately reflect what is going on.
  • Dear Jace ,

    We understand that the screen shot was taken controller was in LPM mode. But We have tried keeping the break point before the controller goes to the LPM mode. " TI_CAPT_Init_Baseline(&one_button) " Should initialize the CAPTIO0CTL Registers. Still they are showing 0x00. Kindly find the screen shot attached.

  • Hello Vijeth,

    With this touch library, every time you take a sample of the captouch elements, the state of every register the library is saved and then restored after the sampling is done. This includes the CAPTIOxCTL Registers. So the only time you would see them as configured for capacitive touch would be if you happen to stop the MSP430 during debug as it was taking a capacitive touch sample.