This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP-TS430PW14: SBW communication not working

Part Number: MSP-TS430PW14
Other Parts Discussed in Thread: MSP430F2002, MSP430F2013, MSP-FET

Hello Team,

I am working with a customer who is developing with the MSP-TS430PW14 for SBW communication. 

Details:

The problem that I’m having is connecting to an MSP430 using Spy Bi Wire. I am able to connect to the part using JTAG, but I will need the use the SBW for this project.

 

They have an MSP-FET, and a MSP-TS430PW14. The MSP-TS430PW14 came with sample MSP430F2013. Their intended target will be a MSP430F2002.

 

They are running CCS v7.2.0.00013.

 

The CCS did upgrade the MSP-FET firmware when they first connected it.

 

Out of the box the MSP-TS430PW14 came configured for SBW. During debug, they got the following message.

Error connecting to target : Unknown Device


It was tried with both the sample MSP430F2013, and a MSP4302002 with the same result.  Then reconfigured the MSP-TS430PW14 for JTAG, and they were able to successfully connect and debug. 

This has been tried on 2 different Windows 10 machines with the same result.

The cables came in the box with the unit and even replacing them with alternatives did not work

  • micro USB cable w/ ferrite
  • 6” 14 pin ribbon cable (They don’t have a shorter cable) 

The MSP-TS430PW14 came configured for SBW (J7-J12 all set 1-2). The Vcc jumper (J5) is set to int. 

Originally a CCS ‘Blink the LED’ project targeting the MSP430F2013 was attempted. With the ‘out of the box’ SBW configuration, they were not able to connect to the target. By simply changing to JTAG (changing J7-J12 to 2-3), it was able to connect and run, and debug. 

Then created a ‘fresh’ CCS ‘Blink the LED’ Project targeting an MSP430F2002, replaced the actual MSP430F2013 with an MSP430F2002, and repeated the debug attempt with the same results as above.

 After more discussions with the customer last week, they found that hanging a scope probe on the reset pin of the part (pin 10), caused the part was detected in SBW, but the subsequent “trouble writing memory block” error occurred. : Trouble writing memory block at 0xfc00 on page 0 of length 0x4c 

They have repeated these tests by trying to run on a completely different computer with an independently installed CCS and freshly created project. So, that this is a completely different workspace. 

It has been verified (with the scope) that the 3.3V is stable during the SBW debug attempt. 

To summarize:

While using all the above TI provided parts, devices, cables, etc…, they are able to install CCS, use CCS to create an example ‘Blink the LED’ project, then successfully program the part and debug while using 4 wire JTAG only

2 wire SBW does not work

Hanging a scope probe on the target reset line facilitates connection to the part while in SBW configuration, but does not allow programming of the part.

Is there any other suggestions that the customer can try to get the SBW connection up and running ? 

I appreciate your time and support towards this case.

Sincerely,

Kishen