This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/TIDM-1004: Example project file

Part Number: TIDM-1004

Tool/software: Code Composer Studio

Hi,

apologies in advance for basic question.Having purchased the Access Control Panel with bluetooth low energy and capacitive touch dev kit, I cannot locate the project files to evaluate the deign.

Can anyone guide me to the actual location of  the project "ble-lock_dev_MSP_EXP432P401R_tirtos_ccs", also all the SDK's are current to date.

Many thanks

Narendra

  • Hello Narendra,

     You can find the projects in here TIDM-432CAPELOCK Software:

    After you import the "blelock_MSP_EXP432P401R_tirtos_ccs" project, this other project "tirtos_builds_MSP_EXP432P401R_tidm1004_ccs" will also get imported.

    I just tested it with the latest SDK v1.50 version and CCS v7.2 and it worked for me. The image below have the properties for the tirtos_builds_MSP_EXP432P401R_tidm1004_ccs project.

      Hopefully this helps.

         David

  • Hi David,

                             Many thanks for your response, I did post this yesterday but not to you direct so apolgies for repatition.

    Unfortunately I am still experiencing the same issue when importing the project "blelock_MSP_EXP432P401R_tirtos_ccs" into Code Composer Studio. I have tried on both Ubuntu 14.04lts and windows 7 both 64bit machines. The error message is as follows.

          Error: Product 'com.ti. SIMPLELINK_MSP432_SDK_BLUETOOTH_PLUGIN' v0.0 is not currently installed and no compatible version is available. Please install this product or a compatible version.

    I have downloaded” ccs_setup_7.2.0.00013”, “simplelink_msp432p4_sdk_1_50_00_12" and "simplelink_msp432_sdk_bluetooth_plugin_1_20_00_42"  from your site and installing into "c:\ti" on the windows machine and similar equivalents onto the Linux box. The project files within the zip file ("tidcd85") has been unpacked into a project folder.

    Using the "Import CCS Projects... option under "Projects" tab within the Code Composer studio, I have selected the project above and attempted to load. Am I missing any additional installs?

    The plugin is registered please see the below.

    Any help is apreciated.

    Regards

    Narendra

  • Hi Narendra,

    I noticed hat you marked this thread as answered, just wanted to confirm that you were able to import and build this example successfully. Please let me know.

    Thanks,

    David
  • Hi David,
    Sorry No this issue is still ongoing, please read my posts.sorry did not realise I had marked as resolved.
    Regards
    Narendra
  • for your info:

    Further to my request for help with loading the demo project "blelock_MSP_EXP432P401R_tirtos_ccs", I have found that by dropping down to version1.10.0.42 of the SimpleLink MSP432 SDK Bluetooth Plugin", I am able to load the project, however I get build errors irrespective of the version of the MSP432 SDK or MSP432 Blue tooth plugin . Currently tried a combination of MSP432SDK (V1.4 and V1.5) and MSP432 Bluetooth Plugin (V1.00.00.80, V1.10.00.42 and V1.20.00.42). The error message is as below :

    >> Compilation failure
    gmake[1]: Leaving directory `/home/dev/ti/ccs_workspace_v7.2/tirtos_builds_MSP_EXP432P401R_tidm1004_ccs/src/sysbios'
    Build of libraries failed.
    subdir_rules.mk:10: recipe for target 'build-903957791-inproc' failed
    "/home/dev/ti/simplelink_msp432p4_sdk_1_50_00_12/kernel/tirtos/packages/ti/sysbios/knl/Swi.c", line 483: error: identifier "Error_IGNORE" is undefined
    1 error detected in the compilation of "/home/dev/ti/simplelink_msp432p4_sdk_1_50_00_12/kernel/tirtos/packages/ti/sysbios/knl/Swi.c".
    gmake[1]: *** [BIOS.obj] Error 1
    gmake: *** [/home/dev/ti/ccs_workspace_v7.2/tirtos_builds_MSP_EXP432P401R_tidm1004_ccs/src/sysbios/sysbios.aem4f] Error 2
    error: xdc.cfg.SourceDir: "/home/dev/ti/xdctools_3_32_02_25_core/packages/xdc/cfg/SourceDir.xs", line 209: xdc.cfg.SourceDir : Build of generated source libraries failed: exit status = 2:

    js: "/home/dev/ti/xdctools_3_32_02_25_core/packages/xdc/cfg/Main.xs", line 160: Error: Configuration failed!
    gmake: *** [package/cfg/release_pem4f.xdl] Error 1
    gmake: *** Deleting file `package/cfg/release_pem4f.xdl'
    gmake: *** [package/cfg/release_pem4f.xdl] Deleting file `package/cfg/release_pem4f.h'
    gmake: *** [package/cfg/release_pem4f.xdl] Deleting file `package/cfg/release_pem4f.c'
    js: "/home/dev/ti/xdctools_3_32_02_25_core/packages/xdc/tools/Cmdr.xs", line 52: Error: xdc.tools.configuro: configuration failed due to earlier errors (status = 2); 'linker.cmd' deleted.
    gmake[2]: *** [build-903957791-inproc] Error 1
    gmake[1]: *** [build-903957791] Error 2
    gmake[1]: Target 'configPkg/linker.cmd' not remade because of errors.
    gmake: *** [all] Error 2
    subdir_rules.mk:7: recipe for target 'build-903957791' failed
    makefile:125: recipe for target 'all' failed

    **** Build Finished ****
    Buildfile generation error occurred..
    Cannot build project. Referenced RTSC Configuration project 'tirtos_builds_MSP_EXP432P401R_tidm1004_ccs' contains build-errors.
    Build stopped..

    I could really do with some assistance,I need to review the demo kit as per purchase. Please advise on findings, I can import the "blelock_captivate_ccs" project and build succesfully, as this does not pull in the tirtos project.

    Regards

    Narendra
  • FYI - this got fixed in this other thread e2e.ti.com/.../628991