This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BOOSTXL-BATPAKMKII: Charging and Discharging Problem

Other Parts Discussed in Thread: MSP430F5529, MSP-EXP430F5529LP, LMP90100,


I got a new BOOSTXL-BAKPAKMKII and was using it to power up my MSP430F5529. The system was working well and at some point it stopped. First, I thought that the battery was discharged completely. So, I plugged the fuel tank to desktop computer via USB cable in order to charge it. The "charge active" LED was on when I first plugged it. I left it for almost 48 hours, not on purpose. However, when I came back the LED was off. I tried it but the output is approx. 2 Volts. I plugged it again but this time the LED stayed OFF. I checked the connection and then I plugged it carefully and I saw that the LED is blinks for like tenth of a second and then goes OFF. I left it in charge for a while. 

Then I used a multimeter to measure the output voltages from both 3.3V and 5V pins. They both show around 1.5Volts. Interestingly both output decreases in a stable manner as they were discharging over a capacitor. More surprisingly even though I changed the switch from "Connect" to "Disconnect", I was be able to see the same output values around 1 Volt and the discharging patter. Now both output show 0 Volts, as they were discharged. 

Could you please help me about this problem?

Kind Regards

  • Hello Murat,

    The charge active LED only turns on if the current going into the battery is above a certain threshold. It sounds like a short could be involved. What are the jumper settings of both boards and position of the toggle switch? Does the MSP430F5529 work when powered through the eZ-FET lite?

  • Dear Ryan,

    Thank you very much for the answer. I left my office and could not provide you the exact jumper settings. The toggle switch was "ON", that's for sure. I used dip connected the BATPAK over MSP430F5529. It worked for couple of weeks and then stopped. 

    Before I saw your message I have tried these things:

    1. I had a BOOSTXL-BATTPACK as well. When I connected the LİPO of BATPAKMKII to BATTPACK module and try to charge, the "charging" LED was ON.

    2. I tried to charge the LİPO of BATTPACK from BATPAKMKII module, the "charge active" LED was ON.

    3. I powered MSP430F5529 with BATTPACK, everything was fine.

    4. I changed the LİPO's; that is I disassembled the LİPO from BATTPACK and connected it to BATPAKMKII. Everything worked fine. After half an hour I realized that the the system was off. I checked and found that the output of the LİPO was zero again. I tried to charge, no luck. So, it happened again. "Charge active" LED blinks for a very briefly and then goes off. To sum, the same thing happened when I use the old LİPO from BATTPACK.

    I am going to post the whole connections tomorrow.


  • Dear Ryan,

    As I said the toggle was "CONNECT". The BATPAKMKII was plugged on MSP-EXP430F5529LP launchpad.

    We are using 5V, GND, P3.3(RX), P3.4(TX) pins for a bluetooth communication.

    We are using a LMP90100 for 2 infrared temperature sensors. So there is an SPI connection between MSP-EXP430F5529LP and LMP90100. 3.3V, 5V, GND, P3.2(SCLK), P2.5(CSB), P2.4(DRDYB), P3.0(SDI), P3.1(SDO).
    I was using the system with BOOSTXL-BATTPACK. I have charged it couple of times without disassembling it. Then I got a new BOOSTXL-BATPAKMKII and kept using the system for couple of weeks until the battery went off. We did not change literally anything in the design. After the battery went off I tried to charge it but no luck.
    BTW, the system works fine when I power up the MSP-EXP430F5529LP via mini-USB connection. 
    As I said my previous message I am having the same trouble for both LİPO's and for BATTPACK and BATPAKMKII.
  • Dear M,

    Please make sure that all MSP-EXP430F5529LP eZ-FET lite jumpers are unpopulated when the BOOSTXL-BATPAKMKII is connected. I am trying to loop in someone who has more expertise with this battery BoosterPack to help answer your questions.  Once more, please send all jumper configurations.


  • Dear Ryan,

    I am using only the pins and connections I wrote above. Nothing is connected to ex-FET lite jumpers. Moreover we did not change a single thing in the launchpad. But if you are asking something apart from these by saying "jumper configurations", I did not get it. I am sorry. Could you please provide me some more details?

    Btw, I forgot to mention that I always disassemble the (both) BOOSTERPACK from MSP-EXP430F5529LP and try to charge but it does not work. 


  • Hi Murat,

    Were you able to find any resolution to this issue? Do you have any updates to provide?  I will mark this post as closed, it will open back up once responded to.


**Attention** This is a public forum