This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP432P401R: Issue with MSP432 Launchpad to BOOSTXL-EDUMKII LCD interface

Part Number: MSP432P401R


I'm having some issue getting the MSP432 launchpad to work with the LCD on the BOOSTXL-EDUMKII, on Energia IDE.

All other examples worked except those related to the LCD where I only get a white screen.

The hardware is ok as I'm able to run the LCD related sample code supplied in the MSP432 Simplelink lib, but that's with CCS.

Was wondering if anyone has the same issue with the Energia LCD sample proejcts and any insights to what was wrong.

I'm using Energia 1.6.10E18 and the Energia MSP432 EMT RED BOARD lib, the other MSP432 BOARD LIB doesn't work with the sample projects.

Tried LCD_Joystick, LCD_LifeGame and LCD_screen_test project.

Appreciate any insights/advice.



  • Generally, the LCD drivers for Energia/Arduino are for LCD's connected directly to the GPIO pins. In your Energia sketch do you init the LCD with 6 or so pin numbers?

    As shown in the attached image, the LCD on the boosterpack is connected via SPI. You will have to use SPI on the Energia to communicate with it.

  • Hi Keith,

    Thanks for the suggestion. The JoystickLCD project I'm running is a demo code that comes with the MSP432 library installation in the Energia Sketch. I briefly looked at the initialisation code, it appears to have the usual class declaration for the LCD drivers and the .begin() function that is associated with typical Arduino sketch so I supposed that author should have configured the LCD interface to the MSP432 Launchpad.

    I can dig into the code to investigate but the point is this is a default demo code that comes with the MSP432 Lib installation package in Energia so I would expect that to work out of the box. I saw some queries with the same white screen issue with the same project on the web and in this forum (dated 2015) so I thought whatever issue would have been resolved by now. Which means I probably made some silly mistakes when trying to run this demo code.

    Can someone from TI comment on this?

    I did see recommendation online to use other IDE such as embedXcode+ but that means users will continue to experience the issue of demo code for the hardware not working out of the box when they buy this kit.


  • OHL,
    I cannot comment on the installation package. I would recommend going ahead with your investigation into the code and sharing your results in the Energia space (

  • Chris,

    Will likely go with CCS if we choose this platform. I was looking at Energia since its lib supposedly offers a ready set of examples to have a quick feel of what can be done. Won't be straight forward to debug what seemed to be a tool related issue from the comments I see online, especially with a sketch type of IDE.

    It'll be good if your contact window with Energia could drop them a note to fix that. Would be a waste if the adoption of a good hardware is impeded by non-functioning out-of-box demo code in the field.

  • Thank you for the feedback. I will pass along.


**Attention** This is a public forum