This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Linux/MSP430F417: MSP-FLASHER Rapsberry ?

Part Number: MSP-FET
Other Parts Discussed in Thread: MSP430F417

Tool/software: Linux

Hi, i try use the MSP Flasher on Raspberry but the library ( is for Intel architectures. I need the library for ARM. There is some solution, for this?


  • Hello,

    Could you please provide more detail on what you are trying to do? Are you trying to program a Raspberry Pi? I am wondering because the title of your post is referencing the MSP430F417 so I am a little confused about what your question is referring to.

    Best regards,

  • i need to use MSP-FETFlash with Raspberry Pi3 But i can't build
  • Okay I understand now, you are trying to program an MSP430 device using a Raspberry Pi. I did a quick search online and found some forums and threads with solutions using the dll's provided in the msp-debug-stack. Please refer to the following resources:

    - Program TI Launchpad with Raspberry Pi

    - E2E: MSP430F5309: MSPflasher compiled to run on ARM architecture

    - 4-wire JTAG with mspdebug and Raspberry Pi GPIO

    Best regards,


  • Thank you for you replay (sorry for my english). I going to try these links.

    Best regards,

  • Part Number: MSP-FET

    Tool/software: Linux


    I already compiled the library, for ARM (Raspberry Pi 3 B), (slac460y from MSPDS-OPEN-SOURCE and i compiled MSPFlasher-1.3.18. I followed this tutorial:
    But, i have the next error:
    * -----/|-------------------------------------------------------------------- *
    *     / |__                                                                   *
    *    /_   /   MSP Flasher v1.3.18                                             *
    *      | /                                                                    *
    * -----|/-------------------------------------------------------------------- *
    * Evaluating triggers...done
    * Checking for available FET debuggers:
    * Found USB FET @ ttyACM2 <- Selected
    * Initializing interface @ ttyACM2...done
    * Checking firmware compatibility:
    * FET firmware is up to date.
    * Reading FW version...done
    * Setting VCC to 3000 mV...done
    * Accessing device...
    # Exit: 16
    # ERROR: Device database not loaded.
    * Powering down...done
    * Disconnecting from device...done
    * ----------------------------------------------------------------------------
    * Driver      : closed (No error)
    * ----------------------------------------------------------------------------

    It also compiled the same library (slac460y) for INTEL and y have the same error.

    Best regards

  • Hi Agustin,

    I went ahead and merged the new thread you made regarding  your issues programming the MSP430 with the Raspberry Pi because it is a continuation of the support you are receiving on this thread. For future posts, please keep posts regarding the same issue local to the initial thread.

    Please refer to the  MSP Flasher User's Guide to see if the operating system you are using is actually supported by the software. In general, we do not support the Raspberry Pi platform so that is why I linked some articles and threads that might point you in the right direction.

    Another option you have is to reach out to the Raspberry Pi support forum and community to see if anyone else has run into the same issue. Here are the following links for those forums:

    Best regards,


  • I uderstand this from your post:
    1. You were able to compile in Linux PC and connect to your device using mspdebug tilib command?
    2. You are not able to reproduce the same in raspberry pi (with ARM hardware)

    Is this correct? If not can you explain which part I did not undertand correctly?

    Can you tell me what is the output when run 'mspdebug tilib' from command line, both in your pi and PC?

  • i compiled in RaspBerry Pi 3 B (ARM) and Linux PC (intel) and i've got the same issue:
    With mspdebug in Raspberry:

    mspdebug tilib
    MSPDebug version 0.22 - debugging tool for MSP430 MCUs
    Copyright (C) 2009-2013 Daniel Beer <>
    This is free software; see the source for copying conditions. There is NO

    Found FET: ttyACM0
    MSP430_Initialize: ttyACM0
    Firmware version is 31300601
    MSP430_VCC: 3000 mV
    tilib: MSP430_OpenDevice: Device database not loaded. (error = 98)
    tilib: device initialization failed
  • I had a similar issue for a different application:

    It was solved by adding a call to MSP430_LoadDeviceDb() after MSP430_Initialize();

    You can place this call in tilib driver files. In tilib.c, do_init() function initializes the connection for mspdebug tilib. Can you place a call to MSP430_LoadDeviceDb(NULL) right after MSP430_Initialize() and check if it works? 
    Also, can you also try using the latest version of mspdebug? 

  • Thanks Archie. I resolved the issue. I was install mspdebug from Website ( of Daniel Beer and works fine. Woks with mspdebug but not with MSP Flasher.