This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/EZ430-F2013: MSP-FET430UIF JTAG Tool Error

Part Number: EZ430-F2013
Other Parts Discussed in Thread: UNIFLASH

Tool/software: Code Composer Studio

Hi guys, fairly new to the community so please excuse any transgressions.

Just got myself an ez430-F2013 development stick to evaluate the MSP430 as a basic microcontroller for small personal projects.

I've been trying to get it to work with CCS v8 for the past few hours since I got it but it appears that my laptop can't seem to install the drivers for the device.

Key Points:

1) Using CCS v8 because I'm running a 32-bit laptop

2) The ez430 shows up in Device Manager as "MSP-FET430UIF JTAG Tool", but it seems no driver is available for the device despite having installed CCS

3) I reckon it's coz of (2) that CCS can't identify it as a target to load my code into the f2013

3.1) Tried installing UniFlash 5.2.0 (as per suggestion in another thread) as well as older versions of CCS hoping they may have the drivers, didn't work.

4) I stumbled upon a number of threads both here in E2E and in the wider Internet with a Google search, with this one exactly mirroring the issue I got:

https://www.embeddedrelated.com/showthread/msp430/34345-1.php

5) 

Is it really an issue originating from the factory? If it is, are there any options for a replacement to be shipped to me? And if it isn't, where could I get my hands on the drivers or a solution to this issue?

See attached pic for better understanding.

Ignore the Unknown Device, I believe it's my laptop's ambient light sensor that's been broken for a while now, so very much unrelated to the issue at hand.

Many Thanks...

  • Shoot, forgot the pic, here it is:

  • Hey Erei,

    First off, What lead you to choose this EVM to start with?    I would actually recommend all new user's to start with an MSP430 launchpad like this: http://www.ti.com/tool/MSP-EXP430G2ET 

    I'm not sure exactly what your issue is.  The fact that it's showing as a MSP-FET430UIF leads me to believe the EEPROM is not blank.  

    When you installed Code Composer v8, did it prompt you to install files for MSP430?  Do you have have a MSP430ware folder? (probably c:\ti\msp430ware_xx_xx_xx)    This should install the correct EZ430 drivers.

    Here is a sample GPIO toggle function you can import into CCS to make sure it's not a project settings issue: http://dev.ti.com/tirex/explore/node?node=AM0gs1m9YFSwx5NqcuXykw__IOGqZri__LATEST 

    Thanks,

    JD

  • Thanks for the reply JD,

    It's largely due to the compactness and relative portability... I saw it as the kind of thing you have on standby near you that you can pull out and tinker with when something came to mind, as opposed to the larger LaunchPads. 

    CCS did prompt me to install all the MSP430 files, and I currently have MSP430ware_3_80_07_00 in my ti folder.

    Tried reinstalling CCS v8 as well, no dice...

    As for the example code, I can't flash it to the f2013 because CCS keeps telling me it can't find a USB FET to flash things to, which lead me to look into Device Manager in the first place, to discover that the 430UIF wasn't talking right to my laptop...

  • Hey Erei,

    Very sorry for the delay, were you able to get it working?  

    I'm really not sure issue is here.  The launchpad is slightly bigger, but I still think it's pretty portable.  I have several in my bag at all times.  I'll send you a message/friend request on E2E and can sample you a launchpad to test with.   

    Also, I'll be traveling the next week for the holidays.  

    Thanks,

    JD

  • Sorry JD, thing's still dead in the water.

    Tested it with a different laptop running 64-bit and the latest version of CC and it still doesn't show up...

    - - - - -

    Thanks for the offer, just responded to your request :)

  • Erei,

    I found your post after a search because I was starting a project that would use an old EZ430 I had.  I experienced the same problems you described.

    I have several older versions of CCS installed on my workstation; have not run them for a while.  I opened CCS 6.1.2 and created a project.  I was successful in running the debug and loading the program.

    I have not investigated further and do not know what the problem with CCS is ( I have been using 8.3.0)

    Anyway, hope this is helpful

    Joey