This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP-EXP430G2: The filename, directory name, or volume label syntax is incorrect error

Part Number: MSP-EXP430G2
Other Parts Discussed in Thread: ENERGIA, MSP430G2553, , MSP-EXP430FR5994

I ran the blink example on my board a couple days ago with no problem but today no code (not even blink) will upload to the microcontroller giving me this error message

Energia: 1.8.11E23 (Windows 10), Board: "MSP-EXP430G2 w/ MSP430G2553"

C:\Users\USERNAME\Documents\energia-1.8.10E23-windows\energia-1.8.10E23\hardware\energia\msp430\cores\msp430\atof.c: In function 'atof':

C:\Users\USERNAME\Documents\energia-1.8.10E23-windows\energia-1.8.10E23\hardware\energia\msp430\cores\msp430\atof.c:71:9: warning: floating constant exceeds range of 'double' [-Woverflow]

Sketch uses 810 bytes (4%) of program storage space. Maximum is 16384 bytes.
Global variables use 20 bytes (3%) of dynamic memory, leaving 492 bytes for local variables. Maximum is 512 bytes.
MSPDebug version 0.24 - debugging tool for MSP430 MCUs
Copyright (C) 2009-2016 Daniel Beer <dlbeer@gmail.com>
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
----------------- NOTE ------------------
Modified version of mspdebug for Energia
Do not use standalone
-----------------------------------------
Chip info database from MSP430.dll v3.3.1.4 Copyright (C) 2013 TI, Inc.

Using new (SLAC460L+) API
MSP430_GetNumberOfUsbIfs
MSP430_GetNameOfUsbIf
Found FET: HID0023:COM5
MSP430_Initialize: HID0023:COM5
Firmware version is 20409001
MSP430_VCC: 3000 mV
MSP430_OpenDevice
MSP430_GetFoundDevice
Device: MSP430G2xx3 (id = 0x00de)
2 breakpoints available
MSP430_EEM_Init
Chip ID data:
ver_id: 5325
ver_sub_id: 0000
revision: 00
fab: 60
self: 0000
config: 00
Device: MSP430G2xx3
MSP430_Run
prog: 'C:\Users\USERNAME\AppData\Local\Temp\arduino_build_179844/Blink.ino.hex': The filename, directory name, or volume label syntax is incorrect.
MSP430_Close
An error occurred while uploading the sketch

I've already tired updating the drivers and that didn't solve the problem.

  • Hello Almas,

    something got corrupted on your PC's SW-setup.

    From the current information it could in the easiest case be the project.

    I would try to start a new "blink example" or any other example to make sure it is just your blink project that is affected.

    If problem persists; you might need to re-install CCS (if it was that IDE you intended to use).

    Please tell me if you intended to use Energia, and please tell me which version it.

    have a nice day and good luck

         Johann

  • Hi Johann,

    I'm using energia-1.8.10E23 and I have tried to run other examples and I get the same error message.

  • Hi,

    I installed Energia on an older Win7-I7 notebook. Am using the MSP-EXP430FR5994 as target.

    No issues invoking from the unzipped folder. Moved folder around; No issues with "blink" nor "fade".

    I then ran the same tests on an WIN10-I5 notebook  => no issues.

    I will observe if after the next win updates something will change; I rather doubt it.

    My recommendation: Just extract Energia again and see if the problem is gone then.

    have a nice day

        Johann

  • Hello again,

    same error message came up on mine !!! (please understand I'm a bloody newcomer to Energia)

    Here is the solution...:  Energia seems to block some actions as soon it detects that new updates are available.

    Just restart PC and/or Energia; a small message box will appear notifying that new updated are available.

    Update; after update all runs fine again. I have now tried on the 'FR5994 board and the 'FR5739 board. Both are working.

    I got a similar experience you had:  without update the board that was working before ('FR5994) seemed to not work anymore !!!

    It showed a similar error message starting with the 'atof' line (I agree this line is misleading...).

    Since I did the same updates on two separate notebooks I had the chance to take a snapshot on the 2nd notebook update.

    You should see a screen  as below ...  (then you are on the right way)

    have fun with your Energia coding, and sorry for the inconvenience...

        Johann

  • Hi Johann,

    Thank you! This resolved my issue.  I restarted Energia, no luck, and then my PC, no luck as well.  I also didn't see the prompt you got so I went to the board manager manually and updated there and it worked.