This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430F5359: Reading out memory with bootloader (BSL) does not appear to work.

Part Number: MSP430F5359
Other Parts Discussed in Thread: MSP430F5436A, , MSP-FET

I have been working on getting the bootloader (BSL) for our application (using MSP430F5359 and MSP430F5436A processors) and have been able to get write and mass erase commands to work using the bsl-scripter application but the memory read out feature appears to fail silently. 

The following is returned when I run the readout command, but the file MAIN_READOUT.txt is not created. No error messages are returned, and I am able to successfully program application images using the command: BSL-Scripter.exe -d --initComm [COM14,UART,9600] --device MSP430F5xx -b pass.txt -w MAIN.txt which works as expected.

Log mode is turned on!
BSL-Scripter.exe -d --initComm [COM14,UART,9600] --device MSP430F5xx -b pass.txt -r [MAIN_READOUT.txt, 0x8000-0xA3A0]
Verbose is turned on!
Device : MSP430F5xx
Init communication parameters : [COM14,UART,9600]
RX_PASSWORD pass.txt
        Read Txt File  : C:\ti\BSL-Scripter\pass.txt
        [80] [21] [00] [11] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff]
        [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff]
        [ff] [ff] [ff] [ff] [9e] [e6]
        <80> <02> <00> <3b> <00> <60> <c4>
        [80] [21] [00] [11] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff]
        [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff] [ff]
        [ff] [ff] [ff] [ff] [9e] [e6]
        <80> <02> <00> <3b> <00> <60> <c4> <00> <00> <00> <00> <00> <00> <00>
        BSL Password is correct!

I inspected the packets transmitted with my o-scope and the read command does not appear to actually sent at all. I also tried running the password command followed by the read command as shown below and the read command does not get sent.

BSL-Scripter.exe -d --initComm [COM14,UART,9600] --device MSP430F5xx -b pass.txt

BSL-Scripter.exe -d --initComm [COM14,UART,9600] --device MSP430F5xx -r [NIBP_MAIN_READOUT.txt, 0x8000-0xA3A0]