This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC430F6137: UART Problem When Only DC Powered - wihout Debugger

Part Number: CC430F6137

Hi everyone,

My problem is so weird and I couldn't handle it. 

I have a customized board which uses CC430F6137 uP and I programmed it. I would like to implement UART application and my code is that ;

#include <msp430.h>
#include "cc430x613x.h"
#include <msp430.h>
#include <string.h>
void terminal_write();
void UART_open();
void UART_close();
void main(void) {

WDTCTL = WDTPW | WDTHOLD; // Stop watchdog timer
//__delay_cycles( 2 * 1e7);

printf("system working\r\n");


//_bis_SR_register(LPM3_bits + GIE);



void terminal_write(char *info)
unsigned int i;

unsigned int len = strlen(info) ;



void UART_open(){
P1SEL |= BIT5 + BIT6;
//UART Settings
UCA0BR0=3; //UCA0BR0 = 3 ; //32Khz / 9600 –>> 3
UCA0BR1=0; //UCA0BR1=0; // BAUD 9600; ( UCABR1 * 256 ) + UCABR0 = UCABRx see "slau259e.pdf"

UCA0MCTL=6 ; // see "slau259e.pdf" page 602 //
//UCA0MCTL =| BIT7 | BIT6 | BIT5 | BIT4 | BIT3 | BIT2 | BIT1 | BIT0 |
// |------- UCBRFx --------------|----UCBRSx----------|UCOS16|
// for 9600 baudrate at 32kHz UCBRFx = 0 , UCBRSx = 3 , UCOS16 = 0
// | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0 |
// 0b00000110 = 0x06 = 6
void UART_close(){

P1SEL &= ~(BIT5 + BIT6);


I'm using FET430--UIF debugger and there is no problem with it. If I run my program with debugger than it runs and there is no problem with UART communication but if I try to run it without debugger 

[I mean there is no need for debugging operation , I expect that program can run without debugger] I can't see any UART output when I use DC power supply(3.3 volt).Beside if I use only debugger without 3.3 v power supply then I can't receive the output signals properly. If I use both power supply and debugger than I can get the signals properly.

Thanks for your replies.



  • Hello Huseyin,

    Have you consulted section 3.5 of the MSP Debuggers User's Guide? Is the MSP430 the only thing consuming power or do you have external circuitry on your custom board that consumes power? What is the current limit of your external 3.3V power supply?

  • Thanks Aaron ,

    I solved my problem , it's about my missing connection. Problem is that connections of the Vdd and common ground has to be tied together. I already use common ground but I have not used the Vdd connection together beacuse I thought it's not important. However if you don't use the Vdd connections together than it may cause a problem. Sometimes it's run properly when I wasn't tied they but as I sad you probably deal with this problem on your project because of the voltage incongruity. 

**Attention** This is a public forum