This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430I2041: Error when I use on Uniflash load image file

Part Number: MSP430I2041
Other Parts Discussed in Thread: MSP-EXP430F5529LP, UNIFLASH, MSP430F5529, TIDM-3OUTSMTSTRP, MSP430F67791A, TIDM-3PHMTR-TAMP-ESD, EVM430-F6779, MSP430F67791, MSP-ISO, EVM430-I2040S, MSP-FET

I use Software EMDC ver 1.140.00.03 on MSP430i2041 to measure energy three line of phase. https://www.ti.com/tool/MSP-EM-DESIGN-CENTER 

 

I use kit MSP-EXP430F5529LP to debug, but it error when I use on Uniflash load image file “TI_MSP_HIDBRIDGE__1_00_04_00__MSP-EXP430F5529LP.txt” to MSP430F5529

http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/EnergyMeasurementDesignCenter/1_40_00_03/release/EnergyMeasurementDesignCenter_1_40_00_03/docs/users_guide/html/Energy_Measurement_Technology_Guide_html/markdown/ch_designcenter.html

 

I use CCS build code for MSP430i2041.

Now I have 2 project use MSP430i2041 with one phase and MSP430F67791AIPZR LQFP100 for three phase with LCD segment.

  1. With MSP430i2041. When start I use project TIDM-3OUTSMTSTRP but now I want use CT for measure, project TIDM-3OUTSMTSTRP can’t modifier from Rshunt to CT. In my project use 3 IC MSP430i2041 to measure 9 line of phase or three line of three phase. IC master communication with MSP430i2041 over I2C.
  2. In project use MSP430F67791A, I use TIDM-3PHMTR-TAMP-ESD. If I want use it on EMDC with LCD display I can’t use it.

 

Debug over EMDC its have problem Load Image file.

 

 

 

  • Hello,

    Cong Nguyen Thanh said:
    I use kit MSP-EXP430F5529LP to debug, but it error when I use on Uniflash load image file “TI_MSP_HIDBRIDGE__1_00_04_00__MSP-EXP430F5529LP.txt” to MSP430F5529

    Please provide more details about the specific error. You can also search the forum for the error and see if there are any related threads that would help resolve the error. I would also recommend removing any other USB devices such as MSP-FETs and not use any USB hubs.

    Cong Nguyen Thanh said:
    With MSP430i2041. When start I use project TIDM-3OUTSMTSTRP but now I want use CT for measure, project TIDM-3OUTSMTSTRP can’t modifier from Rshunt to CT. In my project use 3 IC MSP430i2041 to measure 9 line of phase or three line of three phase. IC master communication with MSP430i2041 over I2C.

    You can create a custom i2041 project in EMDC for the TIDM-3OUTSMTSTRP design. Keep in mind that EMDC is not compatible with any software provided with the TIDM-3OUTSMTSTRP reference design. You can adjust the EMDC project and sensor settings based on the design's schematic and sensor parameters.

    Cong Nguyen Thanh said:
    In project use MSP430F67791A, I use TIDM-3PHMTR-TAMP-ESD. If I want use it on EMDC with LCD display I can’t use it.

    EMDC can be used on the EVM430-F6779, but again, it is not compatible with the original software provided by the TIDM-3PHMTR-TAMP-ESD reference design. You would need to add the LCD support to the EMDC-generated code. The results can be observed in the EMDC GUI, so the LCD is not necessary but can be used.

    Cong Nguyen Thanh said:
    Debug over EMDC its have problem Load Image file.

    EMDC is not intended to be used as an IDE. It's used to communicate with a supported MSP430 and send/receive commands and data over UART.

    Regards,

    James

  • This is error when connect Uniflash with kit MSP-EXP4305529LP. I want convert to HID mode.

    Now i use EMDC creat project with MSP430i2041. I have some problem.

    1. I understand value UART baud (250k with SMCLK 16384000 Hz)

    #if (EM_SMCLK_FREQ_IN_HZ == 16384000)

    //250K Baud Rate @ 16.384MHz
    #define UART__PRESCALER (0x04)
    #define UART__FIRST_STAGE_MOD (0x00)
    #define UART__SECOND_STAGE_MOD (0x03)

    Baudrate on the https://e2e.ti.com/support/microcontrollers/msp430/f/166/t/881658?MSP430I2041-UART-Communication-issue

    After calib, i will connect with master device Over UART and I2C.

    I want use baud rate 115200, what is value of baudrate set in code EMDC? 

    2. In I2C_SLAVE mode have error 

  • Nguyen van Dung said:
    This is error when connect Uniflash with kit MSP-EXP4305529LP. I want convert to HID mode.

    What version of UniFlash are you using? I'd like to try duplicating this on my side. Please describe when the issue happens during the programming process.

    Nguyen van Dung said:
    I want use baud rate 115200, what is value of baudrate set in code EMDC? 

    I'm not sure I understand. You mentioned earlier that the EMDC baud rate is 250k baud (which is correct) but here you're asking what the baud rate is. You can change the baud rate if that's what you're asking but it won't work with the EMDC GUI anymore. That may be fine since the GUI just emulates a host MCU or processor in your system.

    Regards,

    James

  • Uniflash Version: 6.2.0.3059. I follow http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/EnergyMeasurementDesignCenter/1_40_00_03/release/EnergyMeasurementDesignCenter_1_40_00_03/docs/users_guide/html/Energy_Measurement_Technology_Guide_html/markdown/ch_designcenter.html  to click the “Load Image”. When I click Load Image this show error "Error!   spawn ./DSLite ENOENT"

    When I use EMDC need connect KIT_5529LP to msp

    UART Baudrate need modifier because after calib by EMDC, I can test data over UART to PC.  I will use Master board read result from MSP430i2041 over I2C_SLAVE .

    I have other board MSP430F67791A - LQFP100 merter Three phase diplay in LCD and use UART send data to board master. With this board, how to connect program by kit MSP430F5529LP to MSP430F67791

    Regards,

  • Hello,

    Nguyen van Dung said:

    I'm not sure why you're seeing this error. I used both UniFlash v6.1 and v6.2 with my MSP-EXP430F5529LP, and it programmed the HID .txt image without errors. Perhaps your onboard debugger needs to be updated. You could try programming your board with a simple F5529 code example using CCS or CCS Cloud. CCS Cloud may install the DSLite components which may help this error. Try that and then come back and try to use UniFlash again.

    Regards,

    James

  • Nguyen van Dung said:
    I have other board MSP430F67791A - LQFP100 merter Three phase diplay in LCD and use UART send data to board master. With this board, how to connect program by kit MSP430F5529LP to MSP430F67791

    That's covered in the Communication section in the EMDC Technology Guide. Note to future readers: Please make sure you're referencing the latest version of the software and documentation.

    Regards,

    James

  • How jumper set on KIT MSP430F5529LP to Load Image.

    How to connect KIT MSP430F5529LP to MSP430F67791? or connect eZ-FET on KIT to MSP430F67791

    I am modifier UART baudrate, but i can't read da ta from MSP430i2041 over UART. You have code example connect read data from MSP430i2041. Can you send to me example code.

  • Nguyen van Dung said:
    How jumper set on KIT MSP430F5529LP to Load Image.

    All jumpers except RTS and CTS. Those shouldn't make a difference.

    Nguyen van Dung said:
    How to connect KIT MSP430F5529LP to MSP430F67791? or connect eZ-FET on KIT to MSP430F67791

    You can refer to this link in the EMDC Technology Guide.

    Nguyen van Dung said:
    I am modifier UART baudrate, but i can't read da ta from MSP430i2041 over UART. You have code example connect read data from MSP430i2041. Can you send to me example code.

    For interfacing with the EMDC-programmed MSP430i2041 over UART, you'll need to use the EMDC protocol described in the EMDC Technology Guide. You can find the UART code examples in Resource Explorer at dev.ti.com.

    Regards,

    James

  • I have program MSP430F5529LP over CCS  Version: 10.1.1.00004, but can't program HID over UniFlash. I don't stand why it can't connect Uniflash to KIT MSP430F5529LP, step by step I do follow EMDC User guide, but I successful download it over CCS.

    Now i need program and calib value on MSP430i2041 over EMDC, then i connect MSP430i2041 over I2C with master device.

    How to set jumper on KIT MSP430F5529LP and connect it to MSP430i2041 or MSP430F67791A to calib in EMDC over HID.

    MSP430i2041 and MSP430F67791A is my new design, 

    MSP430i2041 same schematic in TIDM-3OUTSMTSTRP but measure current by CT.

    MSP430F67791A  same schematic in  TIDM-3PHMTR-TAMP-ESD.

    After calib on EMDC i will use IC master read data result of MSP430i2041, please help me.

    Regards.

  • I successful download code HID for MSP430F5529, HID connected but don't connect to device and not display in Status Bar with Device Name and FW ID, only display HID Connected. In Result tab not display of value same at Fig. 27 3 Phase Results of http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/EnergyMeasurementDesignCenter/1_40_00_03/release/EnergyMeasurementDesignCenter_1_40_00_03/docs/users_guide/html/Energy_Measurement_Technology_Guide_html/markdown/ch_designcenter.html#communication

    I don't have MSP-ISO board, i connect HID board (3.3V, TXD, RXD, GND) to MSP430i2041 (3.3V, RXD, TXD, GND) but it not run.

  • Nguyen van Dung said:
    I successful download code HID for MSP430F5529

    Did you do anything to resolve the error in UniFlash?

    Nguyen van Dung said:
    HID connected but don't connect to device and not display in Status Bar with Device Name and FW ID, only display HID Connected.

    Check your connections. Reference the connections in the schematic to know exactly which pins you should connect as mentioned in the EMDC Technology Guide.

    Nguyen van Dung said:
    I don't have MSP-ISO board, i connect HID board (3.3V, TXD, RXD, GND) to MSP430i2041 (3.3V, RXD, TXD, GND) but it not run.

    That's fine. The MSP-ISO board provides isolation when working with high voltage. If you're trying to connect to the EVM on a bench, it is not needed. If you're using the EVM, you may want to use jumper wires and logic analyzer probes to connect to the fine-pitch UART header on the EVM.

    Regards,

    James

  • James Evans said:
    Did you do anything to resolve the error in UniFlash?

    No, I download by CCSudio

    James Evans said:
    Check your connections. Reference the connections in the schematic to know exactly which pins you should connect as mentioned in the EMDC Technology Guide.

    I have check connect follow EMDC Guide by pass MSP-ISO, Connect P3.4 P3.3 MSP430F5529 (HID). But in EMDC only display on Status Bar "HID connected" don't show "device name and firmware ID". I have test with sample project and creat new project.

    I have test with Project EVM430-i2040S_SH_1V_1C_50Hz, i have run and receiver data from MSP430i2041. 

    I have creat new project with MSP430i2041 hardware same TIDM-3OUTSMTSTRP but use CT replace SH.

    If I use project with 1 CT - Only Phase_A (not use Phase_B and Phase_C) project can connect HID and display value on Result tab. 

    If I use 2 - 3 CT(PHASE_A + PHASE_B or PHASE_A + PHASE_B + PHASE_C) then chip not run, and can't connect with HID.

    I have test CT or Shun Resistor, it the same.

    I test new connect: Voltage with SD24_CONVERTER_0 and CT with SD24_CONVERTER_2 or SD24_CONVERTER_3. I don't receiver data on HID, I thing code have problem with SD24_CONVERTER_2 and SD24_CONVERTER_3.

    Can you check SD24_CONVERTER_2 and SD24_CONVERTER_3 of MSP430i2041 for me. 

    Regards,

  • Nguyen van Dung said:

    This is error when connect Uniflash with kit MSP-EXP4305529LP. I want convert to HID mode.

    A few questions about your UniFlash error:

    -What host OS are you using?

    -Does your user account have admin permissions to your PC? If not, was the software installed (including ti cloud agent) from a separate admin account?

    Thanks

    ki

  • Ki said:

    -What host OS are you using?

    -Does your user account have admin permissions to your PC? If not, was the software installed (including ti cloud agent) from a separate admin account?

    I use Windows 10 Pro 19042.804 by admin. This morning, I reinstall Uniflash its run ok.

    I program use Uniflash with MSP430F67791A have error. I have test with SBW (SBWCLK, SBWDIO, 3.3V - DVCC, GND, no Crystal) and JTAG (TDO, TDI, TMS, TCK, TEST, RESET, GND, DVCC - MSP430F67791A) schematic same TIDM-3PHMTR-TAMP-ESD. But it can't program . I have program Uniflash successfull with MSP430i2041.

    Thanks

  • Nguyen van Dung said:
    I use Windows 10 Pro 19042.804 by admin. This morning, I reinstall Uniflash its run ok.

    That's interesting. Thanks for letting us know the reinstall fixed the issue.

    Nguyen van Dung said:
    I program use Uniflash with MSP430F67791A have error. I have test with SBW (SBWCLK, SBWDIO, 3.3V - DVCC, GND, no Crystal) and JTAG (TDO, TDI, TMS, TCK, TEST, RESET, GND, DVCC - MSP430F67791A) schematic same TIDM-3PHMTR-TAMP-ESD. But it can't program .

    What's the error? Please be more specific. Can you program the MSP430F67791A using the MSP-FET and CCS? Is this a custom board or an EVM?

    Regards,

    James

  • Hi James.

    James Evans said:
    What's the error? Please be more specific. Can you program the MSP430F67791A using the MSP-FET and CCS? Is this a custom board or an EVM?

    I have program the MSP430F67791A on KIT MSP430F5529LP useing Uniflash and CCS by custom board Crystal 32.768Khz. I follow  Energy Measurement Technology Guide.

    Can you check for me MSP430i2041, I have some test with it in Reply "Mar 3, 2021 3:31 PM

  • I have program the MSP430F67791A on KIT MSP430F5529LP useing Uniflash and CCS by custom board Crystal 32.768Khz. I follow  Energy Measurement Technology Guide.

    Let's save the F6779A discussion for another thread. Let's focus on the i20xx for now. It seems like you got everything to program correctly.

    Can you check for me MSP430i2041, I have some test with it in Reply "Mar 3, 2021 3:31 PM

    Sure, thanks for posting the screenshots.

    I have check connect follow EMDC Guide by pass MSP-ISO, Connect P3.4 P3.3 MSP430F5529 (HID). But in EMDC only display on Status Bar "HID connected" don't show "device name and firmware ID". I have test with sample project and creat new project.

    Don't forget about connecting GND between i20xx and F5529. Also, be very careful how and when you're powering the i20xx. If you're turning off the power to the i20xx but still have the UART pins connected to the F5529, the device is violating the max input voltage and the i20xx could be back-powered off the UART pins - not good and won't work correctly. My suggestion is to (a) always power up the i20xx before connecting the UART pins or (b) keep the UART pins connected but keep the F5529 powered off until i20xx is powered up.

    If your design doesn't consume more current than the F5529 LaunchPad can provide, consider powering the i20xx from the LP. Just make sure to use 3.3V and NOT 5.0V.

    I have test with Project EVM430-i2040S_SH_1V_1C_50Hz, i have run and receiver data from MSP430i2041

    I have creat new project with MSP430i2041 hardware same TIDM-3OUTSMTSTRP but use CT replace SH.

    Another tip. Always use the same EMDC project with its generated code. If you use code generated from another EMDC project, it probably won't work. Make sure you save your new or custom EMDC projects. Sometimes, you may need to close/re-open the EMDC GUI after saving the project. I think there's a known issue related to this mentioned in the v1.40 EMDC Technology Guide.

    I test new connect: Voltage with SD24_CONVERTER_0 and CT with SD24_CONVERTER_2 or SD24_CONVERTER_3. I don't receiver data on HID, I thing code have problem with SD24_CONVERTER_2 and SD24_CONVERTER_3.

    Using different sensors or converters is fully supported. However, like I mentioned, you must use matching EMDC project and code. I would not recommend modifying the same EMDC project and generating multiple versions of the code. This may be why you're seeing an issue.

    Regards,

    James

  • Using different sensors or converters is fully supported. However, like I mentioned, you must use matching EMDC project and code. I would not recommend modifying the same EMDC project and generating multiple versions of the code. This may be why you're seeing an issue.

    Ok, I have reinstall Uniflash and EMDC, this have run ok. This thread can close.

    Thank you so much.