This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

TIDM-1019: Manual Calibration - USS

Prodigy 225 points

Replies: 7

Views: 474

Part Number: TIDM-1019

Hi,

I've several questions about the "Manual Calibration"

I'm using the last version of USS (02_20_00_18), and UltrasonicWaterFR604x_02_20_00_08 

1)

The following step is still necessary if i want to use "Adv. Calibration Table" ?

Comment out the gUssSWConfig.algorithmsConfig->numOfMeterCalibrationRanges=0, in the USSLibGUIApp_Init() function inside of USSLibGUIApp.c file

2)

For the calibration, how do i set the 0 ? I've a mean value of -0.05 at 0 liter/h




3) On the LCD screen, the Volume stay at 0, Is this a feature to enable in the code ?

After the calibration, i want to check my settings on a testing bench. For the test,I need the volume to stay at is actual value when the flow rate is at 0 liter/h (question 2) and the volume to increase when the test is starting.

Regards,

Maxime

  • Hello,

    I am forwarding this request over to an expert in the USS applications team. Thank you for your patience.

    Best regards,

    Matt

  • In reply to Matt Calvo:

    So, can you help me ?


    Regards,


    Max

  • In reply to Maxime Thomaere:

    Max,

    I will ping the applications engineer again who will be providing further support. My apologies for the delay.

    Best regards,

    Matt

  • In reply to Matt Calvo:

    Hello Max,

    that case was assigned to me; I am not the right person for that (yet); I talked to our specialist approx 1hrs ago he will take over.  My apologies.

    best regards

       Johann


    Please verify the answer by clicking the green  "RESOLVED MY ISSUE " button in case the reply solved your question.

  • In reply to Johann Zipperer:

    Hello Maxime,

    1. No, you do not need to make any changes to the code if you are using the 2.20.00.08 version.

    2. In order for this to work, you need to set the flow minimum(from the main calibration tab) to a negative value that handles the most negative value you will see.  The error % makes sense as infinity since this is calculated with Vcalculated - Vexpected / Vexpected, so this is dividing by 0.

     3. This should not be the case.  Be sure that you send the updated calibration information using the "update calibration" button.  Another thing to keep in mind is that if you are changing the number of volume flow rate calibration ranges, you need to generate headers and rebuild the project with these headers, then perform the "update calibration".  This rebuild is required to allocate the memory properly.

    Best Regards,

    Eddie

    Don't forget to verify answers to your forum questions by using the  Verify Answer  button.

  • In reply to Eddie LaCost:

    Hello Eddie,

    I don't understand why i've so much difficulty to make the calibration. I've found something weird

    This is the current parameters :

    This is a ADC  Caputre at 0 L/h

    From the ADC i think my settings are OK

    Then, all my calibration points

    First problem, Why the error stay at 0% at range 3 calibration points 1 and 2 ?

    I generate the headers, rebuild the project, flash my card

    Then i "Read MCU Configuration" and the value are not correct at all, why ?

    if I "Update Calibration" and then "Read MCU Configuration", the value are still not the right one, why ?

    The only thing i've change to the original code is the tweak for the meter constant (https://e2e.ti.com/support/microcontrollers/msp430/f/166/p/819556/3046022#3046022)

    Regards,

    Maxime.

  • In reply to Maxime Thomaere:

    Hello Maxime,

     

    It looks like you have your range 2 calibration points set too wide, which is why the 42.021 point cannot meet the expected error. For range 2, you may want to change the range to something like 42lph to 400lph. If needed, you could add another calibration range to ensure you get the accuracy required across all ranges.

     

    I also notice that you have the maximum VFR set to 4,000, but your actual maximum is higher. You could set this higher, but it actually shouldn’t have any effect. I think this is just used for the GUI checks.

     

    In the case of range 3, you only have 2 points so the theoretical error is zero in a linear regression model.  If you add more points in this range, you will see this change.

     

    In regards to the update calibration not taking your data. I think this is likely due to #define USS_ENABLE_VFR_METER_CALIB being set to false in your USS_userConfig.h file. When you generate the headers, you need to ensure that “Adv. Calibration Table” is checked on the waveforms tab for this to be set to true in the header file. Alternatively, if you generated the header files without this checked, you can just manually set this to true in USS_userConfig.h with the code below.

     

    //Setting USS_ENABLE_VFR_METER_CALIB to false will result in unexpected behavior
    //between the device and the calibration tab of the GUI
    #define USS_ENABLE_VFR_METER_CALIB                    true   
    

     

    Best Regards,

    Eddie

    Don't forget to verify answers to your forum questions by using the  Verify Answer  button.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.