Please note that E2E has undergone a major upgrade. Before logging in, please clear ALL your browser's cache and cookies.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

How to recover MSP430F55xx JTAG fuse using USB BSL

Other Parts Discussed in Thread: MSP430F5525, MSP430F5529

Hi,

I would like to know the procedure to recover the MSP430F5525 device with JTAG fuse blown.

In order to test the USB BSL & fuse feature I tried to blow the security fuse of  MSP430F5529( on MSP-FET430U80USB).
The Fuse is blown properly but I am not able to recover it through the USB BSL.

I am using the "MSP430 USB Firmware Upgrade Example (v1.1.3) " GUI to access the MSP430,
the USB BSL is working fine and I am able to download the firmware like "Blink LED Example"
but not able to erase the security fuse data.

I tried to erase the flash using Demo Scripts from "slau319d.zip -> BSL files"
the erase_pass.txt and ff_pass.txt gets executed properly as shown below
but the security fuse remains even after mass erase.

Starting
Mass erase occured!
Password Sent Successfully
Sending RAM BSL v00.05.04.34
Done RAM BSL v00.05.04.34
Sending C:\......\ff_pass.txt
Firmware Sent
Verifying memory
Memory successfully verified
Total programming time is 0s
Resetting Device...
Starting application
Done!

I have also tried with BSL_Scripter.exe tool but was not successful.

Please let me know if there is a procedure to Recover JTAG fuse using USB BSL.

Regards
Prad