This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMS570LC4357: TMS570 is locked

Part Number: TMS570LC4357

I am working on TMS570LC4357 HDK.  Board was working after flashed a code, after some times stopped working.  

[ERROR] Dap: Error connecting to the target: (Error -241 @ 0x0) A router subpath could not be accessed. A security error has probably occurred. Make sure your device is unlocked. (Emulation package 9.3.0.00032)

I tried: https://e2e.ti.com/support/microcontrollers/hercules/f/hercules-safety-microcontrollers-forum/514045/tms570-is-locked/1866658#1866658 but no luck.

Can you please help me to solve this issue

  • Hi Suthan,

    It looks like the code you programmed is making the part enter an exception state repeatedly. This prevents the CPU from entering a debug state, resulting in the behavior you observe. You need to try to erase the part, assert and release nRST to see if the erase command is able to halt the CPU and erase the flash.

    Please try this procedure to let CPU enter a debug state:

    1. Open the target configuration window, and launch the selected the configuration
    2. Switch to debug window
    3. Press the reset (nRST) button and hold it
    4. Click “Connect Target” immediately after you release the nRST button
    5. The board should be connected after couple tries
  • QJ,

    I have tried more than 100 times. But it is not working. I noticed the following:

    When I click "Connect Target" I got the following error:

    After clicking the "Retry" I got the following message.

  • Is the nERROR LED on? 

    Is the board powered properly? Please check the LEDs for power rails: 3.3V, 5V, and 1.2V.

    Is the LED D12 (near the FTDI chip U27) turned on when the xds110v2 SUB cable is plugged onto the microUSB port? 

  • nERROR - OFF

    Power rails LEDs - All ON

    LED D12 - ON

  • It's good. The HW is ok. 

    When you tried JTAG re-connection, did you press/release the nRST button while clicking the "connect the target"? or just click the "Retry" of the message window you posted?

  • When I click "Connect the target" I got dialog box shown in Figure 1 (always)

    When I click on "Retry" button I got the dialog as shown in Figure 2

  • #1. Press the reset (nRST) button and hold it    --- S3 on HDK

    #2. Click “Connect Target” immediately after you release the nRST button

    When the message windows (Figure 1 & 2) pop up, click "cancel", and repeat #1 and #2