This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.


Part Number: DRV2511Q1EVM

I have a new DRV2511Q1EVM out of the box that is not recognized by USB.

This is what I did.

- Install and opened Haptics Control Console

- In Haptics Control Console Tools menu, selected the DRV2511

- Connected micro USB connector from EVM to PC (Green 3.3V LED lights)

- Haptics Control Console in "Connection" status says "Hardware Not Connected"

- Device Manager show no new devices

Tried different cables, USB ports and PCs with the same results.

I also tried applying +5V to J5 with no change.

According to the user guides, the DRV2511Q1EVM comes out of the box ready to communicate with Haptics Control Console. All jumpers appear to be in the correct positions.

  • Hello, 

    Do any of the LEDs on the board come on when you plug in the board? The 3.3V LED should at least light up to show the board has power. Also, if you go to help->Firmware Updater, does the device show up as a BSL device? If so, the firmware needs to be updated. The proper firmware should have been downloaded when you installed the haptics control console. If the device doesn't show up as a BSL device, you can also try putting the device in BSL mode by holding down the BSL button while you plug in the USB connection. 

    Best Regards, 

    Justin Beigel

  • After updating the firmware, the EVM is recognized. Thank you.