Due to the U.S. Thanksgiving holiday, please expect delayed responses during the week of 11/22.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DRV8701: DRV8701: Problem PSpice for TI with DRV8701

Part Number: DRV8701

This is aki.

I'm not familiar with PSpice for TI yet, and I'm sorry for the rudimentary question.
I have a question about the link below.

e2e.ti.com/.../drv8701-problem-pspice-for-ti-with-drv8701

I faced the same problem that Philipp Schneider faced here. That is, the following error message.

ERROR (ORPSIM-16551): Floating point computation failed during Device / Model Load. Possible solutions: 1) Ensure that all device parameters are in valid range. 2) Try using .options LIMIT

The solution seems to be to apply the DRV8701 correct simulation file shown in this link, DRV8701_PSPICE_TRANS.zip, to PSpice for TI, but I don't know how to apply it, please let me know.

  • Hi Aki,

    Have you tried following the steps outlined in that E2E post? I attached a corrected PSPICE model which should work. There were some issues with the device parameters in the original PSPICE_TRANS model which I fixed for Phillip.

    In order to use the corrected model, download the model I attached in the E2E post, open it with Pspice, and follow the instructions I outlined to configure the simulation.

    If you still have problems, please reply back to this comment.

  • Hi Pablo

    Thank you for your reply. 

    This time, in your reply, I understand that you have attached a remodified model, but I can't find a link for that model. I'm sorry if my understanding is wrong.

  • Hi Aki,

    Attached to this reply is the model4214.DRV8701_PSPICE_TRANS.zip

  • Hi Pablo

    Thank you for sending the file.

    Double-clicking DRV8701E_TRANS.DSN in the unzipped folder automatically launches PSpice for TI.
    And PAGE1 of DRV8710E_STARTUP_18V_6mA was able to simulate well.

    However, for DRV8701E_STARTUP and DRV8710E_STARTUP_14V_150mA,

    QUESTION (ORCAP-15051): Current schematic that you are editing is not in the simulation hierarchy. Do you want to continue?

    Came out. So when I make active the simulation profile and try again,

    ERROR (ORCAP-15052): Simulation failed because of netlisting errors. Resolve the errors reported in the session log and retry the simulation.

    I get the error. The session log at that time is

    ERROR (ORNET-1122): Pin PH on h-block U1 has no matching port in schematic below
    ERROR (ORNET-1122): Pin EN on h-block U1 has no matching port in schematic below

    It has become. Attach the screen.

    I don't know how to fix this, so please let me know. What is an h-block?

  • Hi,

    I did not have this issue. I did get the "QUESTION (ORCAP-15051): Current schematic that you are editing is not in the simulation hierarchy. Do you want to continue?" message but the simulation ran after clicking "yes". Are you seeing the following files on your screen?

    I suggest modifying the DRV8710E_STARTUP_18V_6mA  PAGE1 document for the simulation. I tried to add the other schematics in the simulation hierarchy but is not working. For now, use the schematic that works and just modify it as you need.

  • Hi Pablo

    The hierarchical tree is also displayed on my screen.

    As you say, it seems better to modify the DRV8710E_STARTUP_18V_6mA PAGE1 as I need.

    But I don't have that time so far, so I can't confirm it right away. This initial issue has been solved by sending me the modified model, so please close it here.
    let's close it here.

    Thank you very much for everything.