This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DRV8872: No current flow through 30 ohm inductance coil

Part Number: DRV8872

Hello,

I am trying to drive a 30 ohm coil using the DRV8872 Driver with a 7V source.

I am sending a PWM signal to the driver that is switching polarity every 200ms each time to get the coil to oscillate back and forth between two magnets.

When testing with a just a resistance load, 30 ohms also doesn't allow any current flow, but a 47ohm resistor and above does allow for proper current flow.

I don't think I've detected the NFAULT pin being pulled low, but I'm not 100% confident in that.

Could there be some current spike from switching polarities? And why does this work with a higher load then?

Thank you in advance!

  • Hello, Colin:

    What is the Itrip setting and current sense resistor?

    Regards,
    Wang Li

  • I have the ISEN pin connected directly to ground, so I believe theoretically the Itrip setting should be the maximum 3.6A.

  • Hello, Colin,

    Do you put any capacitor on the output?  The coil parasitic capacitance and extra output current may not be charged up in 1.5us tocp. In tocp, the high charging current won't trigger the OCP protection. After tocp, this charging current plus the real load current may trigger the OCP protection and try the charging after 3ms.

    To confirm the issue, please check the output capacitor or monitor the output current and voltage.

    Regards,

    Wang Li