This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DRV8424EVM: GC Runtime Installation Error

Part Number: DRV8424EVM
Other Parts Discussed in Thread: DRV8424, , MSP430F2617, MSP-FET

I am trying to test the DRV8424 using DRV8424EVM but I am not able to connect it to my PC after installation of the GUI interface. I keep getting the following errors:

"GC Runtime Error" even though the GUI Composer Runtime is installed

"Hardware not Connected. Failed to connect to TI Cloud Agent". I have the TI Cloud agent installed but in this can I am trying to run the system on my PC, not the Cloud

"TICloudAgent Config Error: Cloud Agent not Available"

Could anyone please assist? I am missing something?

  • Hey Olivier,

    Just to make sure, did you try following the steps in DRV84xxEVM GUI User’s Guide?  It specifies GUI runtime v7.4.1 - is that the version you installed?  If you just google "GUI composer runtime" the first few links are for version which I suspect won't work for this board.  

    Beyond that, are you powering the board with the motor power supply when you try to connect to the board?  It shouldn't matter for this board but it's something to try.  The main EVM user guide explains the hardware connectors better, in 2.5 EVM Operation it says not to apply VM/VBAT until after the GUI connects, and suggests manually selecting COM ports.  



  • Hey Jacob,

    Yes, I followed the DRV84XX user guide and used the link in the guide to install GUI runtime v7.4.1. I try powering up the board with the motor supply connected and without. Same result: "Hardware not Connected" and when I go to Option then Ports, it won't let me selected any ports. It say "Not enough ports detected. Please check your USB connections"

    I checked my ports via device manager and I can see that the Com port of the USB is present. Not sure why the GUI Interface doesn't see it.

  • Hey Olivier,

    Okay good.  Hmm odd, is this a work computer or a personal computer?  Sometimes corporate firewall/IT policies can block important things for it.  I assume you've restarted your computer since the software installations?  Maybe try turning off antivirus programs you have running, and make sure you don't have any other programs that might be trying to reserve the COM port somehow.  

    If you click Tools, Log Pane, what does it show on the bottom?  Anything more than the GC runtime error?

    Here's a link to the web version of the GUI if you want to try it:

    I got it working on my computer using TI Cloud Agent 0.5, DRV84xx 0.1.4, and GUI Composer Runtime 7.4.1 when I was messing with this board a month or two ago, so I know it should be possible to get it running.  



  • Hey Jacob, Thanks for the quick reply.

    Yes, this is a work computer. I will try it on my personal one later today and report back.

    when I click tools, it just shows "Application started" in the Logs

    Using the link that you just shared for the web version I am still not able to connect which is very strange. This time it says "Failed to connect to MSP430F2617 device" Could it be my board itself that came damaged? I change the USB cable but still unable to get it to connect.

  • Hey Olivier, 

    When you plug in the USB cable, does a LED on the board start flashing about 1-2 times per second?  That would indicate that the MCU is awake and alive and toggling the LED.  I would need to confirm that the DRV8424EVM has it, but that's a standard feature on our boards.

    Another thing to try - with Micro USB cables, many cables are charge-only and don't have the data communication lines.  Try using a different micro USB cable that you know works for transferring data over it.  Typically these cables are a little thicker or less flexible.  I think the EVM comes with a white one, so if you've been using that cable then I guess that isn't the issue.



  • Many thanks for providing some support Jacob. 

    When I plug in the USB cable, the LED on the board flashes as you described. 

    The cable that I am using is the one that came with the EVM so the communication should not be the issue...

    Other than the TI Cloud agent installation, do I need to install anything else to be able to connect to the web version?

    I just tried it on my personal and the issues are the exact same for the web version and also for the pc install.



  • Hey Olivier,

    Can you try installing the MSP-FET drivers?  Try going here,  click Download options on "MSPDS-USB-DRIVERS — Stand-alone Driver Installer for USB Low-Level Drivers", and download and install the Windows one.  

    For the cloud agent you should have had to install the TI Cloud Agent Extension into your browser: