This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MCT8316AEVM: One Eval Board runs well. The next one shows only MOTOR_BREAK

Part Number: MCT8316AEVM


On my eval Board I tried a setup for a customer.

And create a JSON file ( Save -> File)
Now my costomer want to test it.
He ordered a EVAL board.
Setup up alle jumpfes and switches the same.
But the Software says only MOTOR_BREAK.

But break switch is release?!

Tried to download the JSON servera time...

for a short Period it shows MOTOR_RUN the BEAK again.

No Errors or something.
I tried server option with I2C on / off. or Break pin aktiv... no change...

What is the condition to wirte down a saved config

My board is 5 Month old. ( working, top)

The other one is brand new. ( the I2C jumpers where added befor testing...bottom)
I now left my board at customer side. And tried on a other PC... same...

I also tried a new config with download Default config... no change.

I also checked the switches... right one is break?

But sinal is fine 0V or 3.3V.

Any idear?



  • Hi Andreas,

    Are you able to get the motor to spin using your board? Is the issue seen only on the other board? Can you share the JSON file? 



  • >Are you able to get the motor to spin using your board?

    YES. old board the motor is perfekt. The customer want's to test in real condition befere we desice to create new PCB's

    >Is the issue seen only on the other board?

    YES. If I download the file for 1 sec I see MOTOR_IDLE... the MOTOR_BREAK.

    >Can you share the JSON file? 

    yes, but can't upload with the tool. neither JSON or 7z is working?!
    I added a link to my clould.

    When ist the MOTOR_BREAK display?

    I check also the BEARK signal at the switch and also the test point changes from 0 to 3.3V.

    Also the new board was handeld inside the production under full ESD protection.

    Setup the wire. Connected. Register wirte.... the MOTOR_BREAK.

    very strange...

  • Andreas,

    Thanks for sharing the config file. I see that STAT_BRK_EN is set to 1 which means the device will apply brakes after detecting that the motor is stationary. So, the device enters brake mode after applying speed command. You should see that same behavior on both boards. Refer to  Figure 8-19. Motor Starting-Up Flow in the datasheet for more details. Can you try disabling this bit and check if this resolves the issue? 



  • Hi,

    today I started it again to test what you recommended.
    But today I started. Connected. Load the config. All worked fine. ( No BREAK message)

    Exactly the same as I tried last week 5 times.

    If there something stored in the browser cache?

    The I did you change and worked also.

    I test is now a couple of days.



  • Hi

    tried it serveral times - now all successfully. But I have two questions:

    1. What is the "best" right situstion to do a File Save ( JSON)
        I2C enabled?
        I may be did this when the motor was running?
        When I load the save file -> the I2C is then enabled and a demand is presset. -> maybe this is causeing the problems?

    2. when I have the MCT8316  in   a circuit what is the correct setting to download the EEPROM data?
        in the spec it's just mentioned: Motor is not running.

    Just no demand?
    Read Back the status MOTOR_IDLE? how long?
    RPM read back 0?

    DRV Diabled set?

    Brake set?

    Write a 0 demand before programming?

    Maybe I do this within a bad situation ?

    At this time we programm the EEPROM on each system startup.
    So that we can change the settings via a OTA update of our MCU.



  • Hi Andreas, 

    Save the configuration file after disabling the I2C speed command so that next time when you load the same file, motor will not spin.

    EEPROM data can be downloaded by clicking File-> Save registers 

  • >Save the configuration file after disabling the I2C speed command so that next time when you load the same file, motor will not spin.
    On my side we want to control the device via I2C so disable this will not help.
    Or shall the ADC input tied to ground? ( But basicaly not used at our side)
    The device then depends on what function is enabled by default!
    Is it ok to set the demand to 0%?
    The I2C enable and the demand are in the same register - that should be save?

    >EEPROM data can be downloaded by clicking File-> Save registers 

    Yes that is clear. But what is the right condition to File -> load Register?

    Disable the driver?
    Wait for a specific status?
    Enable the BREAK?

    Because we saw that the motor runs while loading the register!

    This may be cause the trouble?



  • Andreas,

    I2C speed enable bit is a RAM bit which means it cannot be saved in EEPROM. Since you are controlling the speed via I2C, please send an I2C write command to our device to enable this bit. If you want to run the motor immediately after power-up, you can connect the SPEED pin to AVDD and program the device to receive speed command through speed pin (analog mode).

    Save the config file when the speed command is zero (in standby mode).