This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/DRV2605LEVM-CT: Once working code now doesn't work. Pls help

Part Number: DRV2605LEVM-CT
Other Parts Discussed in Thread: DRV2605L

Tool/software: Code Composer Studio

Hello people,

I'm a 3rd year electrical engineer student at Netherlands. I'm doing an internship and my assignment is to develop haptic feedback module.

I have here the dev kit DRV2605LEVM-CT. I'm not very experienced with programming but I understand it.

What I did is I downloaded the sample code from for DRV2605LEVM-CT.

I didn't edit anything except main.c file. I simply hashed all the button functions and tried to make simple actuator running through DRV2605l. I used the adafruit board that already has pull up resistors at it.

It was working really nice, I could select which waveform I want, I made a nice loop and tried to move further with my project.

But suddenly one day I log into code composer studio (v 6.2) and firstly it says there's error with my workspace and it can't find it. After maybe 5 tries it finally started. And when I run the code my actuator didn't vibrate,

every time I pause the code it shows me this fragment :

I'm already spending my second day at office trying to work this out ... Since I have no idea why it happens, it was working and I did try a lot of actuators in a time span of 1 week. No problems at all and my code was working. Suddenly it doesn't. And the thing is that no matter how I edit the code, it will show that it's stuck at this point. Even if I load the unedited firmware code and run it, it will show the same .... So I have no idea what can I do. Every help highly appreciated. Thank you

  • Hello Marcin,

    thank you for posting your problem to E2E.

    I am not a programming expert and am not sure if I can help you with this, so I ll check this with my colleagues, maybe somebody already ran into this kind of problem.

    Till then, try to do the usual troubleshooting (build a new project with your code and try to run it, try to run the original firmware from the new project, resetting the controller, etc.), because it is a bit weird that it had worked before and that it does not any more.

    Best regards,
  • Hi, Marcin:

    what i can think of is to do some cross check.

    the reason may be one of the following:

    1. build environment changed? have you updated the version of CCS before it goes bad?
    2. hardware error, do you have another EVM which you can experiment on?
    3. run a clear build, some intermediate files may go bad

  • The problem was in the hardware. The debug box from TI stopped working plus I changed one thing in the dev board. After getting new debug, and putting the dev board to previous settings. The code works again. Sorry for bothering and thank you for fast replies.

    Kind Regards,

    Marcin Kuchta