The TI E2E™ design support forums will undergo maintenance from Sept. 28 to Oct. 2. If you need design support during this time, contact your TI representative or open a new support request with our customer support center.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DRV2625: DRV2625 Auto Calibration and Diagnostics Process Failled Both

Part Number: DRV2625

Hey,

I am Evaluating DRV2625EVM-MINI Evaluation Board with an Linear Resonant Actuator whish spécification are:

-Vibration-Frecency: 2.5Grms@100Hz(Fact)

-Thermal Resistance: 15.3Ω

-Power Consumption: <300mW @2.23Vrms(Sine Wave)

-Response Time <30ms

Following this Specifications, i have to set Drive Time to 1/(2*Fact)=5ms (see DRV2625 Datasheet at Page 23). But DRIVE_TIME Registor can hold a maximum Drive Time of 3.6ms (see page 54)

I also Have to Set RATE_Voltage register to 0x64 Value as motor Rate voltage is 2.23Vrms. The Clamp Voltage is 2.23*sqr(2)<3.16V so I have to set CLAMP_VOLTAGE register to 0x95 Value.

Please see attached Data for other value that i use for other configuration registers.

Now, when i run Calibration Process (1000ms), the process failled with none Over-current, Over-Temperature or under Voltage detection. The Diagnostics Process also failled with None Error detection.

Am I done something Wrong? How can i Fixed these issues?

Thanks.

DRV2625 Process.pdf