This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DRV2605L: setting frequency with DRV2605LEVM-MD test board

Part Number: DRV2605L
Other Parts Discussed in Thread: TEST,

Hi,

I am testing a few LRA motor using the board DRV2605LEVM-MD with software "Haptic Control Console 1.5.4" (Firmware Version: TI-Haptics DRV2605LEVM-MD v1.3).

The "Run Auto Calibration" process always failed.

So I want to set the resonance frequency myself to run the LRA motors.

I tried to write the value of Reg 0x22 with "Closed Loop" unchecked, but it doesn't seems to work.

Anything I am doing wrong? Can you help?

  • Hi, Ryan,

    Welcome to E2E and thank you for your interest in our products!

    Excuse me, do you have a capture of the main window of the haptics control console (the one that includes the auto-calibration option) to see if everything is configured correctly?

    In addition, are you testing the LRA included in the EVM? Do you have good results with this actuator?

    Any other information you could provide will be appreciated.

    Best regards,
    Luis Fernando Rodríguez S.

  • Hi Luis,

    Please see image below for the interface:

    I am using it to test a mplus 1040 LRA. With "Closed Loop" checked, "Run Auto Calibration" always failed.

    So I want to set a fix frequency by unchecking "Closed Loop" and writing a new value to Reg 0x22. But it doesn't work.

    (tried writing a new value to Reg 0x16 to lower the vlotage, and it works)

  • Hi, Ryan,

    Regarding the on-board actuators, do you have the same results when you use them and run the auto calibration?

    Could you provide the schematic of your LRA sample? Have you glued it to a fixed mass > 100g when running the auto calibration?

    Best regards,
    Luis Fernando Rodríguez S.

  • Hi Luis,

    I don't have a on-board actuator with the board. But "Run Auto Calibration" does Passed when I use LRA from other manufactures.

    This is the LRA that the test board is having trouble with: http://www.mpluskr.com/?page_id=200

    To go back to my question......do the driver IC / test board / software allow me to set a fixed frequency?

    If yes, please let me know the procedure. Or indicate which step is incorrect on the above procedure.

    Thank you!

  • Hi, Ryan,

    Sorry for the confusion, I thought you were using another DRV2605L EVM.

    Regarding your question, yes, the frequency can be fixed but it should be written manually. In order to select the open-loop mode, you need to write '1' on the bit 0 of register 0x1D. 

    http://www.ti.com/lit/ds/symlink/drv2605l.pdf#page=51

    The LRA frequency can be set with register 0x20 (you would need to set it as the actuator period). 

    Please let me know if you have additional questions or comments.

    Best regards,
    Luis Fernando Rodríguez S.