This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

CCS/BOOSTXL-DRV8305EVM: Motor nFault light comes on as soon as I try to run Instaspin lab 11d.

Prodigy 30 points

Replies: 7

Views: 150

Part Number: BOOSTXL-DRV8305EVM

Tool/software: Code Composer Studio

I have changed all the parameters to match my motors, as established using the motorware GUI. The GUI runs one motor just fine, so I know the hardware is capable, but when I try to run them using lab 11d I get the fault light come on. I don't know what I am doing wrong.

I am using the F28069M launchpad with DRV8305 BoostXL boards.

The motor I am using is Quanum MT Series 5208 360KV Brushless Multirotor Motor Built by DYS

Specs:
KV(RPM/V):  360KV
Lipo cells: 4-6S
Max Power: 674.9W
Max Amps: 30.4A
No Load Current: 0.70/22.2V
Internal Resistance:  0.45ohm
Number of Poles: 14
Dimensions(Dia.xL): 63*27.7mm
Motor Shaft: 4mm
prop shaft: 6mm CW prop adapter
Weight: 192g
bolt hole spacing: 25*32*44 M3
Lamination thickness: 0.2mm
Magnets: 42SH
Wire: 18AWG
Connector: 3.5mm bullet

  • Tony,

    Thanks for posting on the MD forum!

    The motorware Labs are supported by the C2000 team, I will forward your post.

    Regards,

    -Adam

  • In reply to Adam Sidelsky:

    Thanks. How do I follow the new post please?

    Kind regards
    Tony

  • In reply to Tony Hannallah:

    Tony,

    I have already moved the post, you will not see anything different, the C2000 team has been notified already.

    Regards,

    -Adam

  • In reply to Adam Sidelsky:

    The GUI can't support dual-motor labs, you have to run the project with CCS directly, please follow the instaSPIN lab guide to get the motor parameters first using lab02c before running the dual-motor lab. Btw, according to the motor spec., the boostxl-drv8305 can't support the motor running with a full load limit to its output capability of maximum current.

  • In reply to Yanming Luo:

    Hi. Thanks for the reply. We now have the software running with two motors successfully. However, I am trying to characterize some different motors using the GUI (so I can drop the parameters into our CCS code). The identify feature runs and stores some parameters, but when I run the motor, the hardware does not run the motor to its full speed rating. 

    The motor I am using is a 

    https://sunnyskyusa.com/products/x5212s

    At 18.3V, with Skywalker ESC:

    https://www.hobbywingdirect.com/products/skywalker-esc-80a-ubec?variant=3471339140

    I can achieve the exact rated speed, RPM (The KV rating is 340 * 18.3V = 6222). The speed I achieved 6228, virtually exactly to spec. 

    With the TI Dev kit and DRV8305 Boost, I could only achieve approximately 4918RPM (both measurements were with the same tachometer). This is over 20% loss in performance, which we cannot accept for our product. Is there anything we can try to achieve the full speed motor drive capability with the TI kit? 

    Appreciate a prompt response as our project deadline is urgent.

    Many thanks

  • In reply to Tony Hannallah:

    I have an update on this.. 

    I found the document page http://www.ti.com/lit/pdf/tiducf1

    "Sensorless High-Speed FOC Reference Design for Drone ESC"

    which seems relevant, as I am using a high speed drone motor. I went through the document and changed the hardware filter, etc. Updated my filter parameter in the code. 

    I successfully identified my motor using lab 2c. I get the following parameters:

    gMotorVars.Rs_Ohm 0.024362523
    gMotorVars.Lsd_H 9.24070662E-14
    gMotorVars.Lsq_H 9.24070662E-14
    gMotorVars.Flux_VpHz 0.007408387

    I have updated the user.h files (for both lab 5b and 11d, as I ultimately need to run two motors simultaneously)

    Unfortunately, now my code does not run. The error checkers through up the 

    USER_ErrorCode_ctrlFreq_Hz_Low error

    I comment out the relevant code and another error is thrown up. So it seems that the parameters identified for my motor by lab 2C are incompatible with the instaspin code. Please can you suggest what these parameters are likely to have conflicted with, and how best to address the issue? 

    In order to try to isolate the problem, I have returned all settings in the User / motor files back to the defaults (pwm freq back to 45kHz, etc), from what the tutorial suggested changing. This has still not fixed it, so I can only assume it's the motor parameters causing the issue. I have had this motor spinning at 4500rpm with the TI hardware, so I know the hardware is capable of spinning. I just need to prove that I can get to the max RPM, otherwise TI will not be suitable for this project. 

    I should note the project is commercial for a sports machine, not for a hobbyist application.

    Thanks

    Tony

  • In reply to Tony Hannallah:

    It seems like you didn't identify the motor parameters correctly, the inductances are too small. Change the identification variables in user.h to run the lab02c again, make sure the motor spin smoothly during the identification process.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.