This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/DRV8353RH-EVM: GUI V2: Different results and removed functions?

Prodigy 220 points

Replies: 4

Views: 82

Part Number: DRV8353RH-EVM

Tool/software: Code Composer Studio

Hi,

I just started developing with the DRV8353RH EVM. I did began my Project with DRV8301-EVM, but due to have more safety margin on the voltage side (we power the Motor Controller with up to 58V), we decided to go with the DRV8353.

So, I had to move from the Gui Composer V1 to the V2. And somehow the results for example for RS are different.

1) Can that be Right? Is one of them inaccurate or does it depend on something else, than not the Motor itself?

2) I see in V2 only a possibility to set the Speed with the Speed reference field. But where can I set a torque like in Gui Composer V1? And also all the nice graphical diagrams are gone… Or is there some hidden button/mode I did not discover yet ?

3) And my last Question: I did migrate the Project 05_b as described and it compiles now. But when I try to start a debug session, Code Composer Studio Comes up with the following: "The program generated by proj_05b is not compatible with any of the CPU's in your target configuration. The program will not be loaded." How can I fix this ?

Thanks in advance

Ferdinand

4 Replies

  • I'm not sure your hardware is compatible with the InstaSPIN GUI in the second screen shot you shared. Have you tried the INSTASPINUNIVERSALGUI?

    Figuring out why you can't connect in CCS will allow us to look at the actual variables in the Expressions view which should help clear things up. What ccxml file are you using to try to launch the debug session? Are you clicking on the toolbar button to launch the debug session or are you opening up the Target Configurations view and launching, connecting, and loading step by step? If you haven't tried the latter, please do so and see if it makes any difference.

    Thanks,

    Whitney

  • In reply to Whitney Dewey:

    Hi

    thanks for your reply.

    Regarding the InstaSpinGUI: This is the gui, which is linked on the product page of the drv8353-evm: http://www.ti.com/tool/DRV8353RH-EVM

    So I think it is the right one. Like I said, I just wondered, why the Gui for the DRV8301 shows different motor identification values than the Gui for DRV8353.

    I saw, that the last version for InstapinUniversalGUI is from September 2015. The DRV8353 is from 2018. Is this version really compatible ?

    Regarding the CCS problem:

    I'm clicking in the toolbar to launch the debug session. I uploaded the ccxml file. So, I', mot sure, which kind of board I do have to select: What kind of board is the logical board, which comes with the DRV8353-EVM ? 

    So, this is the ccxml file:

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>

    <configurations XML_version="1.2" id="configurations_0">

        <configuration XML_version="1.2" id="Texas Instruments XDS100v2 USB Debug Probe_0">

            <instance XML_version="1.2" desc="Texas Instruments XDS100v2 USB Debug Probe_0" href="connections/TIXDS100v2_Connection.xml" id="Texas Instruments XDS100v2 USB Debug Probe_0" xml="TIXDS100v2_Connection.xml" xmlpath="connections"/>

            <connection XML_version="1.2" id="Texas Instruments XDS100v2 USB Debug Probe_0">

                <instance XML_version="1.2" href="drivers/tixds100v2c28x.xml" id="drivers" xml="tixds100v2c28x.xml" xmlpath="drivers"/>

                <platform XML_version="1.2" id="platform_0">

                    <instance XML_version="1.2" desc="Experimenter's Kit - Piccolo F28027_0" href="boards/expkitF28027.xml" id="Experimenter's Kit - Piccolo F28027_0" xml="expkitF28027.xml" xmlpath="boards"/>

                </platform>

            </connection>

        </configuration>

    </configurations>

     

  • In reply to Ferdinand Schmitt:

    I suspect the v2 GUI you downloaded from from the DRV8353Rx-EVM page is likely correct. Although the Universal GUI is old, it is supposed to be more board agnostic than the other v1 InstaSPIN GUI you were using, so I thought it might be worth trying just to see if the results matched the v2 GUI.

    That ccxml seems fine. In case CCS is trying to use a different one to launch the debug session, try launching it step-by-step. Instead of hitting the debug button, open the Target Configurations view in CCS, go to Projects->proj_lab05b, right click the ccxml and Launch Selected Configuration. Once the debug perspective opens, right click on the core you want to connect to (there should only be one) and Connect Target. Then go to Run->Load->Load Program and find the .out for the lab project.

    If that doesn't work, you could try going into the project properties and changing the device variant to "Experimenter's Kit - Piccolo F28027" so it matches the ccxml exactly. Note that this will likely switch the cmd file in your project--delete the one it adds and uncheck "Exclude from Build" on the one that was there before. Rebuild and try to debug again.

    Whitney

  • In reply to Whitney Dewey:

    Hi,

    ok, I will try the universal GUI with the drv8301 again. This should match.

    Regarding the CCS problem:

    I did a reinstall of the drv8353 motorcar files and deleted it from the CCS workspace. I re-added the modified 05b project and now it is launching.So this problem is solved. 

    I will give you an update on the other issue regarding the motor params difference.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.