Please note that E2E has undergone a major upgrade. Before logging in, please clear ALL your browser's cache and cookies.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DRV8305-Q1EVM: help needed getting started with InstaSPIN F2802xF Universal

Part Number: DRV8305-Q1EVM

Hi, I'm some help with DRV8305-Q1EVM.

I compiled proj_lab02b and ran it with InstaSPIN Universal and a BLDC motor, 60KV, 7 pole pairs after selecting the 'test motor' in user.h and changing USER_MOTOR_NUM_POLE_PAIRS to 7, it trips half way through the ramp up phase, then shudders at the end of the test and lights the red led labled nFault on the EVM board, though it does say it has identified, however because the fault led is lit it wont respond until cleared, where it loses its ID. What should I change to successfully identify this motor without tripping into a fault state?

Thanks,

Neil

  • Ah, I found the document "InstaSPIN Projects and Labs User’s Guide" and looked through that. I think the procedure is a bit misleading though as the lab projects given dont include proj_lab02a, only proj_lab02b but unless you go through proj_lab02a you cant actually progress.
    Anyway, my motor is properly configured now.
  • Sorry for the confusion Neil, glad to see you were able to move forward. We've worked to clarify the Lab Guide for the upcoming MotorControl SDK, hopefully things will be clearer from then on out

    Sean