Please note that E2E has undergone a major upgrade. Before logging in, please clear ALL your browser's cache and cookies.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DRV8305-Q1EVM: Changing INSTASPIN USER_MOTOR parameter

Part Number: DRV8305-Q1EVM

Dear support team

I want to change USER_MOTOR_MAX_CURRENT of Lab02b project.

So I changed USER_MOTOR_MAX_CURRENT in user.h file , rebuild project and load .out file.

But motor max current is not changed in GUI and max speed is not decreased.

Please help about it. 

Regards

Tomohiro Nagasawa

  • Hi Nagasawa-san,

    The user.h file contains definitions for multiple motors. Are you correctly selecting which motor definition you're using when compiling? Above where the "USER_MOTOR_xx" parameters are all listed, there are a number of lines that look like

    #define USER_MOTOR motor_model_number

    All but one of these lines will be commented out. Can you check and make sure the un-commented motor model is the same motor model that you are changing the max current setting for?

    Thanks,

    Garrett

  • Hello Garrett-san

    I use DT4260-24-055-04H-TI  motor and defined Anaheim_BLY172S in user.h.

    The procedure of changing is as follows. Are there any mistakes?

    1. Change  USER_MOTOR_MAX_CURRENT value to 10.0

    #define USER_MOTOR_MAX_CURRENT          (5.0)→(10.0)

    2.Crean and build project. Copy and rename .out file 

    3. Launch GUI and configure .out  to EVM

    4.Max current on GUI screen is not changed

    Please give advice about it.

    Regards

    Tomohiro Nagasawa

  • Hello Garrett-san

    This question is solved.

    I forgot save of user.h.

    Thanks

    Tomohiro Nagasawa