This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS65150: Device shuts down after Vgh hits 19.2V

Part Number: TPS65150

Hello, 

Using the TPS65150 to try and hit a V(s) of 10.383V, a V(gl) of -10.02V, and a V(gh) of ~22V. On startup the V(s) hits it's voltage, V(gl) hits its voltage, and then as V(gh) ramps up, the device seems to go into protection. 

I've tried the FDLY cap at 100nF, 200nF, and 300nF. The result is the same at each delay, shutdown as V(gh) approaches 19V. I should note that V(s) and V(gl) will stay on for the amount of the set FDLY delay, and V(gh) seems to always fire at the set delay. V(gh) appears to be the cause, I'm just not understanding what V(gh) is doing to shut it down.

I've tried CTRL tied to my clock and tied high. I'm going over my math again on V(gh), but was wondering if anyone else had a thought as to what might be going on?

Schematic and scope traces attached. 

Thank you.

*Edit* 

I wanted to add that V(gh) is not present when FDLY is disabled. V(s) and V(gl) output the correct voltage. The behavior is the same across screens, or without a screen attached. 

  • After further examination of the application notes, I figured out that the voltages I was shooting for were too excessive for the part/design. 

    Bringing V(gl) up to ~-6V and V(gh) down to ~14V brought the part back to life.