This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ40Z80: Incorrect cell voltage reading on the BQ40Z80 chip

Part Number: BQ40Z80


We have made our Battery Management System using a BQ40Z80 chip with External cell balancing according to the schematic from TI, the one shown below

On 5 of our BMS, when reading the values on the BQ40Z80 chip from the Battery Management Studio, the cell 1 voltage shows an incorrect value of around 80mV but all other cells show 4150mV. When measuring with a multimeter the voltage on cell 1 reads 4.15V so we ruled out that it was a faulty battery.
Also, we measured the voltage at VC1 and the reading was 4.15V.

The thing to note is that these BMS worked fine at first, but suddenly, and with no apparent reason to us, the BQ chip started to read an incorrect value.

The latest one that stopped working was used for making a golden file. Logging the charge, relax, discharge, relax process for obtaining the ChemID was finished without any issues. The next day, when we wanted to start the learning process, we first charged the battery without the BMS (as the documentation shows that the first step of the learning process was a discharge). When we connected the balancer cable of the battery to the BMS the BQ chip wouldn't wake up as it went into shutdown mode when it read a cell voltage lower than Shutdown Voltage. We woke up the BQ chip manually by connecting batt+ and out+ until we lowered the Shutdown Voltage value so that the BQ chip wouldn't go into shutdown mode. 

Is this a known issue? Could it be a hardware or firmware problem. All cell balancing options from the data flash were turned off on this BQ40Z80 chip and the calibration for Current, Applied Cell 1 Voltage, and Applied VC6-VSS Voltage were done before the logging for the ChemID.

Also, some BMS boards have not had this problem at all and still after one month continue to read correct cell voltage values.

Thanks in advance.

  • Hi Vladimir,

    Can you send me your gg file? Did you use the same exact external cell balancing circuitry as shown in the diagram or were there modifications? Have you noticed any kind of pattern for when this occurs, i.e. it starts happening only after connecting the balancer cable or only when you woke up the gauge?



  • Hi Jessica,

    We used the same circuit as shown in the diagram.

    Our analysis, based on the SLUA420A document, is that the VC1-VC2 voltage is too high for the internal FET when internal balancing is selected on the BQ40Z80 chip, because of the option for multiple FETs to activate at once. 

    To protect from the high voltage, the question is if we can add a 1k ohm resistor on the line between GND and VSS (marked blue on the picture) or if that is not recommended, change the two 1k ohm resistors (marked red on the picture) to 500 ohms or less but keep the rest as they are? Or is it necessary that all resistors are the same? 

    Could you provide information about the maximum Vds voltage for this chip?

    This only happened in instances when the balancer cable was connected. On a few BMS boards, we only connected the Batt cables to give power to the BQ chip in order to switch to external balancing and turn off cell balancing altogether and only then connected the balancer cable to the BMS. In those instances, the chip worked fine.

    The .gg file used is attached.

    Best regards,


    Golden file.rar

  • Hi Vladimir,

    I wouldn't recommend putting the resistor between VSS and GND. You could reduce the resistors but I'm not sure if that would help. Just to clarify, this only happens when the balancer circuit is connected? The gauge reads the correct voltages when it isn't connected? Or does this only occur when cell balancing is turned on in FW?  

    I'll take a look at your gg file in case it is a configuration issue but if it was working before, my guess is that's not what is causing the issue.