This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

UCD3138ALLCEVM150: ROM and Firmware Compatibility

Part Number: UCD3138ALLCEVM150
Other Parts Discussed in Thread: UCD3138A, UCD3138

I ve downloaded  the LLC converter firmware from TI website . 

After building the project in CSS ( im using v6.3 for better compatibility) I obtain the .x0 file.

After obtaining the x0 file , when Im trying to download the firmware via "UCD3xxx Device GUI" 

im getting the error below. 

#if defined(UCD3138A)
#define DEVICE_ID "UCD3100ISO1||141031" //Device id

this is the piece of code where DEVICE_ID is set.

I ve tried to change the name  to " UCD3100ISO1" or tried to make it shorter like "UCD3100ISO1||141031"

none of these worked.

How can I solve this problem and download the firmware into UCD ? 



  • Can you find the device in ROM mode? Before reprogramming, make it sure it is in ROM. You can execute " Command Program to Jump to ROM....)


  • Device is already in ROM mode.

    Also when I try to debug device using CCS , I get the error below

    At this point I dont have any idea to proceed .

    The firmware is from TI  website , I downloaded the suggested versions of both complier (ARM 5.2.4) and CCS ( v6.1.3) .

    How can I solve the downloading issue ? 



  • Hello,

    It seems that you are using UCD3138A device. For UCD3138A, the device id should be something like this:  "UCD3138A||141031".

    UCD3100ISO1" is for UCD3138 device. 

  • I figured that problem was on "linker" .


    Only a few files should be configured to compile as state 32 (ARM mode).

    The only state 32 file are : interrupts.c, standard_interrupt.c, software_interrupt.c, clear_program_flash.c

    the rest should stay in state 16."

    With this information now im able to build and download firmware.