The TI E2E™ design support forums will undergo maintenance from Sept. 28 to Oct. 2. If you need design support during this time, contact your TI representative or open a new support request with our customer support center.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS62840: EVM Circuit Not Working as reference

Part Number: TPS62840

Hi Team, helping a customer,

Designed the circuit according to the EVM schematic. Please see the connection of the evaluation board used for our comparison. The R11=0 resistor was resoldered and connected to a 11.5kΩ to make the output voltage to be 2.5V.

EN->ON

MODE->PFM/PWM

STOP->RUN

R11->11.5KΩ resistor

 

 

 

According to this schematic, I designed the circuit as follows.

EN pin-> Input voltage

MODE pin -> 1M resistor and GND

STOP pin -> GND

VSET pin -> 11.5KΩ resistor

Comparing the current cost by my designed circuit and the evaluation board.

 

The BOM used to assemble is as follows.

U6

1

Texas Instruments

TPS62840DLCR

ULTRA LOW IQ BUCK CONVERTER

8-VFDFN

D4

1

ON Semiconductor

MBR120ESFT1G

DIODE SCHOTTKY 20V 1A SOD123L

SOD-123F

C1

1

Murata Electronics

GRM21BR61A476ME15L

CAP CER 47UF 10V X5R 0805 / 47u

0805

C18

1

Murata Electronics

GRM155R61A475MEAAD

CAP CER 4.7UF 10V X5R 0402 / 4.7u

0402

R6

2

Yageo

RC0402FR-071ML

RES SMD 1M OHM 1% 1/16W 0402 / 1M

0402

R9

1

Yageo

RC0402FR-0711K5L

RES SMD 11.5K OHM 1% 1/16W 0402 / 11.5k

0402

L2

1

Murata Electronics

DFE201612E-2R2M=P2

FIXED IND 2.2UH 1.8A 116MOHM SMD

0806 (2016 Metric)

C19

1

Murata Electronics

GRM155R60G106ME44D

CAP CER 10UF 4V X5R 0402 / 10u

0402

 

 

 

You may consider whether the diode affects the current cost. But we have another version without diode. The designed circuit was as follows. It can be powered directly from VIN pin.

 

The current measured at different Vout (select R9, R10, R11, R12, respectively) are

Hoping for your assistance.

Thank you.

-Mark

  • Hi Mark,

    Can you replace the 1Mohm resistor, R6 in your schematics with a 0Ohm one? The 1MOhm maybe be too high to pull the Mode to GND and let the device operate in PFM. Would be good to take some scope shots of the VOUT, SW and Inductor current to check if you are in PFM.

    What is the load current used in these tests? Was that the same between the tests on the EVM and your board?

    In the tables, you highlighted (in red) just a couple of VINs where the input current consumption was high and it was low for the rest of the VINs. Is it true that the current consumption is high, only for certain VINs?

    Best regards,

    Varun