This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS7H4001-SP: Model for this does not run in TI PSpice

Part Number: TPS7H4001-SP
Other Parts Discussed in Thread: PSPICE-FOR-TI,

Specifically this item: TPS7H4001-SP PSpice Worst-Case Analysis (WCA) Model (Rev. A)

Talked to a friend, he said the model loads and runs in Cadence PSpice, but that does not help me. It needs to run in TI PSpice (I do not have access to this Cadence tool).

Moreover he said, there is no simulation set-up for this model... And the transient results are all over the place (changes a lot based on settings). I looked into the unencrypted model. This model looks like an ad hoc table-based representation of the TPS7H4001 component. It should run fast and the sensitivity w.r.t. to sim settings may be because whoever assembled this model did not test very well; there are no d_by_dt aspects inside the model. But there are small to large capacitances in the test, so dunno… I suspect only need to tighten PSpice default time step a bit? 

If an updated/fixed model can be provided, please also provide the test with sim set-up so I can see if this works properly.

Anyway... Hope you folks can help with this.



  • Hi Bryan,

    TheTPS7H4001-SP PSpice WCA model is an enhanced average model, which is intended for AC simulation only. For transient simulation, you will both need to utilize the transient model. Please note that the transient model is not enhanced to include internal worst-case shifts caused by process/manufacturing variation, voltage, or temperature. 

    I'll need about a day to see if I can recreate your issue with getting the WCA model to run in PSpice-for-TI. Can you provide any additional detail on what the problem looks like? Is the part not appearing in the part library, are there convergence issues when simulating, or is there some other error occurring?

    In the meantime, please let me know if there are any other questions I can address.



  • I do not have an action item to look at the "transient" model. By my definition, WCA normally implies worst-case-analysis model that is typically applied to transient simulation. Via inspection appeared obvious to be an averaged model, but a model only useful for small signal ac? That I did not know... You would think that important salient point would be inserted in the header (else ignorant folks like me, and others folks in TI, colleagues that I asked earlier) would not tried to run this model in transient mode. But that then explains why (for folks that can run this because they have Cadence PSpice) observed all over the place results from transient simulation attempts. ;)

    Now to answer your question... When I attempt to run the model in TI PSpice say... in under a 5ms transient run, I just see an error the transcript window "simulation halted" (during what appeared to be instantiation phase, just before it attempted to get underway). Should be pretty easy to duplicate in TI PSpice. 

    That said... I guess I'll still take the updated model if you can provide it, that works for only small signal ac in TI PSpice. Since I have no idea what the WCA small signal ac results should look like, please provide a sim setup file (that autoplots the relevant signal and results). If you cannot, please let me know, as I need to let my customer know. Thanks...

  • Hi Bryan,

    Thanks for your feedback. Yes, the distinction is not always clear and we have been moving towards explicitly stating details about the simulation capabilities of our models in newer releases. 

    I am able to run simulations without seeing the error you have been encountering. Would you mind sending your project files or at least a screenshot of your simulation settings and schematic? Do you encounter this error with any other models in the PSpice-for-TI library, or just the TPS7H4001-SP WCA model? 

    There is a user guide for this model that you may find useful which I will link to below. It includes information about setting up the sim profile and shows examples of what the results should look like for a default schematic setup.

    TPS7H4001-SP PSpice WCA Model User Guide



  • Hi Sarah... I provided a link to my project files (which is TI's link). My sim setup is simply setting end time to 5ms, which is likely the problem, yes? Cause I'm trying to run this ac centric model in time domain. So... I just set up another sim profile, to do small signal ac from 10 to 100meg wit h1024 pts per decade. Same error...

    --------------- INFO(ORPROBE-3209): Simulation Profile: SCHEMATIC1-ac_run ---------------
    INFO(ORPROBE-3183): Simulation running...
    INFO(ORPROBE-3188): Simulation aborted

    So thinking it could be a directory permission prob, I clicked on the toplevel of project directory and observed it was read only. I attempted to open this (and all subfolders), but it refuses to take (cause when I rechecked it is still read only). Wen I create my own project it is fine. BTW... I'm a developer and I do have write permissions to my own machine. :)

    So this is weird... I pulled the original TI project files from the link I gave you when I filed this case. Incidentally, that project appears to be dated, cause upon first invocation, TI PSPice says... I need to update this and insert into another /1 directory. Did you see that?

    Anyway... Thanks for the user guide link. That is useful... I can just leverage this. I converted this TI model to run in Saber simulator, and that process took 10 minutes, and I can simply set up a test schematic (that mirrors what I see here) and run things there (in Saber) in short order. I have spent (wasted) some time trying to run this in TI PSpice, so likely going to throw in the towel (again trying to get this to run in PSPice). I have run a lot of models and tests in TI PSpice and never had any trouble, until this particular model. Oh well... 

    Thanks for your support...