The TI E2E™ design support forums will undergo maintenance from Sept. 28 to Oct. 2. If you need design support during this time, contact your TI representative or open a new support request with our customer support center.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS65987D: TPS65987D I2C control charger (BQ25723) questions

Part Number: TPS65987D
Other Parts Discussed in Thread: BQ25723, TPS65987, BQSTUDIO,

Hi TI team,

We have a project that used TPS65987 I2C1 to control the BQ25723 charger. 

The BQ25723 can work fine with the BQStudio app. but TPS65987 I2C can't control the BQ25723.

The pjt file is below.

test_tps65987_gpio_power.pjt

While using debug mode. After executing below I2Cw CMD (setting charge current 1280mA), the I2C CLK and SDA will have waveforms. But BQ25723 didn't behave charging. 

Strangely, after executing the I2C CMD, whatever read or write CMD. The I2C CLK will be pulled low. 

Tentatively, under debug mode, execute [GPsh] and [GPsl], and the GPIOx will be set correctly.

Shortly, the TPS65987 worked, both GPIOx and I2C1 can toggle with CMD. The BQ25723 worked well with BQstudio controlled. The I2C1 hardware connections are also good.

I've no idea why BQ25723 I2C1 can't control TPS65987. And why I2C CLK will be pulled low after excute CMD?

Please help! 

Thanks in advance.