This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

UCD90160A: UCD90160A issue - return all data as FF

Part Number: UCD90160A
Other Parts Discussed in Thread: UCD90160

Dear Sir/Madam,

We encountered an issue with the UCD90160ARGCT, which acked to the address we sent over I2C bus, but the data read back are all FF. Here's the steps we did:

1) Reset the chip by toggling the reset pin (low, wait 1s, then pull high); then wait for 2s;

2) Pull the control pin to high;

3) Send Operation command: write 01, 80 (hex);

4) Send on off config: Write 02, 03 (hex)

5) Read back operation: Write 01, Read back get FF;

6) Read back on off config: Write 02, read back get FF;

7) Read dev id: Write AD, read back get FF, FF, FF, FF;

8) Read dev revision: write AE, read back get FF, FF, FF, FF;

Looks like the chip always give back FF for whatever command we sent. May you please help to check:

1) if the chip TI shipped out with firmware loaded? or we need to download the firmware?

2) if any procedure or setting is missed out? or if any hardware pin settings required before sending commands to the chip?

Appreciate if you could help to check and reply as soon as possible, as we are blocking by this issue and it's a quite urgent issue.

Thanks very much,


  • Hi

    UCD90160A is pmbus-centric device and all communication must follow smbus/pmbus protocol. Moreover clock stretching is required.

    Please check section 5.5 of Any protocols not following will cause communication issue.

    base on what you described the write operation is always good(at least the communication is completed successfully) , but read somehow does not work。

    Please provide a i2c waveform for step 3 and step 5. if possible skip step 5.

    Moreover what is 0xAE and 0xAD. UCD90160A does not support these commands. Please follow to understand the supported commands and protocol for each command.



  • Hi Yihe,

    Thanks for the reply. I think the part number is UCD90160 (instead of UCD90160A), and the 0xAD and 0xAE commands are for reading the device ID and device revision.

    I just tried removing step 5) per your suggestion, and still get same result, all data read back are 0xFF.

    Below are captures of 2 write commands and 1 read back command.

    Appreciate if you could take a look and let me know the possible causes.


    waveform of step 3: write 01, 80

    waveform of step 4: on off config: write 02, 03

    waveform of step 6: read back on off config: write 02, read get 0xFF.

  • HI

    For PMBUS read, please use restart after writing command. STOP+START for read is not supported.