This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ40Z50EVM-561: communicate abnormal

Part Number: BQ40Z50EVM-561
Other Parts Discussed in Thread: BQSTUDIO, BQ40Z50, EV2400

Hi team,

Customer encountered that BQ40Z50EVM can't communicate with BQstudio, they use 1s battery (3.8V) connected between 1N and 1P, and short 1P to 4P. The problem was that when they try to communicate with BQstudio, there is no response from BQstudio (They pressed the wake button). Then they continued to press the wake button and tried to communicate with BQstudio at the same time. They found that BQ40Z50EVM still could not communicate with bqstudio normally, and returned to 1717_17_17, shown as below picture. Could you please help to explain why this symptom happened and how to make BQ40Z50EVM communicate with bqstudio successfully. Thanks!

  • Hello Zhihao,

    BQ40Z50 is not set for 1 cell operation by default. The data flash parameter for number of cells must be first updated by applying voltages to the other cells.

    For single cell operation 1P,2P,3P and 4P should be shorted.

    From the description, it looks like someone may have tried to program the SREC to the gauge and it failed. I would suggest programming the srec and then setting for 1 cell operation after it autodetects.

  • Hi Shirish,

     Thanks for your reply. 

    Customer has changed 1s to 3s, but the EVM still can't be communicated well. 

    You mentioned that they should programming the srec, could you please help explain how to programming the srec in detail in case of communication failure. And could you please help provide the srec file which they can programming to fix this issue?

  • Hi Shirish,

    Customer changed new IC on the board, and use 3s battery today, but this issue still can't be fixed.

  • Hello Zhihao,

    bqStudio shows a number for the version, that would not be possible without communication. Try programming the srec again. Make sure to press the wake button on EVM when starting bqStudio and before programming.

  • Hi Shirish,

    I tried to programming the serc again, and pressed the wake button during both start bqstudio and programming. Unfortunately, it's still not work. When I tried to programming the srec, there will be an alert "no acknowledge from device", which made the program can't run normally. Please check this problem, how should I program the srec successfully?

    Furthermore, What confuse me is why even if the IC was replaced by a new one, the device still can't work normally?

  • Hello Zhihao,

    It looks like you may have a bad SMBus connection or the EVM is damaged.

    There is also a newer firmware version of the EV2400 that you can upgrade to, but I don't think that is causing the problem.