This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

UCD9080: UCD9080 GUI not working

Part Number: UCD9080


We have a UCD9080 PMIC in our design and we are trying to program it with the UCD9080 EVM GUI-2.3 (Rev. A) provided by TI and the USB-GPIO 2006 adapter but it seems that the software doesnt recognize the adapter. We have tried in windows 11, 10 and 7 and running the program as administrator. Each time we connect the adapter, the green LED lit and it appears correctly in device administrator in Windows. We have checked the I2C signals with an osciloscope and the signals are not moving. 

We have tried the Fusion Digital Power Studio and it recognize the adapter and the UCD9080: we could read register from UCD9080 with the SMBus/I2C/SAA tool and we could see the I2C signals in the osciloscope.

We think that there is a problem with the UCD9080 EVM GUI-2.3 and we need it to configure the device. What can we do?