This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ25570: Buck output is occasionally too low (1.22V, but programmed resistors are for 1.8V)

Part Number: BQ25570

Hi TI team,

I have tried to implement the circuit for the BQ25570 in an application, however, the output voltage is too low. During testing, it is normally at the programmed 1.8V (or more specifically 1.84V since I didn't have the exact right resistors), but every now and again, it would get stuck in a low output mode or something, where the output is 1.22V. When it gets into this mode, it seems like it doesn't matter what I do, it stays there, even with different supercap voltages, solar irradiances, etc. I have also tried toggling different Enable pins in different orders, but none of that seemed to help. Is it possible that my programming resistors are wrong? Or is there anything else that might cause such behaviour? For reference, here are my resistor values which are from the spreadsheet tool:

  • I found it! Rookie mistake: my prototype had a semi-dry joint, and it seems that the flux was maybe conducting just enough to let it sometimes work and sometimes not work. After reworking that part, and cleaning the board with some IPA, it works consistently now.