This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LM5168FEVM: How to measure the FB waveform in EVM

Part Number: LM5168FEVM
Other Parts Discussed in Thread: LM5168

Hi, I want to know how to measure the FB waveform in LM5168FEVM.

If I have tried used oscilloscope with isolated voltage probe and the multimeter. But these two ways will affect the COT control of LM5168.

How can I measure the FB waveform without affecting the normal operation of LM5168?

Best Regards

Yishan Chen

  • Hi Yishan,

    If you use LM5168EVM, you can use ordinary voltage probe to test the waveform. FB is more susceptible to interference, so you can test with minimal loop between these two test point. 

    Under normal conditions, its waveform is as shown in the figure below. However, if there is interference, the waveform may change. But we have measured it on EVM before and it will not affect normal work. Thanks.

    Aurora

  • Hi Aurora,

    Very appreciated.

    I have measured the voltage in the FB node successfully. The ringing will occur in the MOSFET transition time, is that normal?

    Besides, I have also measured the output voltage ripple. It is around 300mV, is that correct? I can't get the waveform in 9-13 of datasheet. What cause this situation and how can I improved that? 

     

    Blue one is the FB waveform. Yellow one is the output voltage.

    Best Regards

    Yishan Chen

  • Hi Yishan,

    FB is more susceptible to interference, the ring should be introduced by external testing. For below waveform, maybe you need to test with the smallest loop of the voltage probe. Otherwise there will be loud noise. Thanks.

    Aurora

  • Hi Aurora,

    Thank for your help. I was confused that because I have tested it with the smallest loop by the ground pin. 

    Do you know if there are some other reasons that will cause this issue?

    Best Regards,

    Yishan Chen

  • Hi, 

    Can you take a picture of your testing method? At the same time, please mark the test points in the picture. Thanks.

    Aurora

  • Sure

    I have test these three point with ground spring, there are nothing change in the output voltage. It's like:

    Best Regards,

    Yishan Chen

  • Hi Yishan,

    The test method is ok. What is the load when you test? Is it light load or heavy load? The waveform in the datasheet is under 0.2A output. 

    Thanks.

  • Hi Aurora,

    The load is exactly 0.2A.

    By the way, the bandwidth of oscilloscope is 20Mhz, any other action we need to do to ensure the correct measurement in the oscilloscope ?

    customer will want to know the exactly the amplitude of voltage ripple.

  • Hi,

    I rest the Vo_ripple on our LM5168EVM. The results is normal. I test it when Vin=24V, Vo=10V, Io=0.2A. I also use smallest loop to test the vo1_ripple. From the description you gave me, there is nothing wrong with the test method. Maybe you need to confirm with the customer. The value given in our datasheet is right. Thanks.

     

     Aurora

  • Hi Aurora,

    Very appreciated for your support. The reason why we can't measure the actual voltage ripple and FB voltage is because the probe setting and EMI.

    Best Regards,

    Yishan Chen