This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ25731: Can't select the charging current I want

Part Number: BQ25731

Hello, i'm using the bq25731 to charge a 3s battery pack, and I can't get a charging current higher than ~185mA. 
I tried changing the charging current register but the register never changes, it stays at the default value, i tried deactivating the watchdog but no luck so far.
I'm charging on a usb Type-C port so i could get the 1A from it but i ca't get it to charge at this speed no matter what I do.
I'm interfacing the BQ25731 with a PIC 18F47J53

Can anybody help me ?

Thanks

  • Hi Noe,

    There are a couple of situations when the charge current cannot be increased.

    1. If the output power demand is more than the input power. What is the charging voltage and what is the input power of your adapter?

    2. If the battery voltage is very low then charge current is limited as a measure of battery short protection. What is your battery voltage?

    Best Regards,

    Munir

  • 1. My charging voltage is set to 12.6V for a 3 cells series battery. Input power of my charger ? I tried on pc ports and dedicated usb-c charger and it didn't change anything.

    2. I tested on partially empty battery(11.5V), almost empty battery(11V), almost full(12V), and lots of inbetween and it doesn't change anything.

    I have to add that i achieved having the 1 amps charge 1 time but I can't get it anymore.

    Thanks

  • Hi Noe,

    Can you share your schematic and the register map (the values of all the registers) of the charger when this issue occurs? 

    What was the adapter rating that you tried?

    A battery that is almost empty should be close to zero volt. How is the almost empty battery is 11V in your case? 

    Best Regards,

    Munir

  •  Here is the schematics for the BQ25371
    I'll share the register map in a while,

    I tried on my USB-C PC Port, that should be minimum 7.5W(5V-1.5A), and a 5V-3A USB-C dedicated charger,

    Yeah, no i don't think a LiPo battery pack should go to 0V, but you're right it wasn't almost empty. It would be almost empty at 10V(3.33V per cell) as the battery manufacturer state that each cell should not go under 3.2V.

  •  Here are the state of the register when charging on my PC port

  • Hi Noe,

    The register map does not show any fault based on the charge status register 0x21/20. Just to clarify, is this the register map when there was battery attached and you tried to increase charge current? Or is this the register map just after power up without any battery when you were not charging?

    There is nothing wrong with the schematic. So I still think that your adapter is limiting the charge current. With usb-c from pc, input power 7.5W but you are trying to draw 12V x 1A = 12W. In this case your charge current will be below 1A even when you set it to 1A in the register. I could get about 600mA of charge current from laptop usb port with 12V battery on the evaluation board. This is because of the resistive drop across the usb cable. When the charger tries to draw more current from the adapter the resistive drop across the adapter cable will cause the voltage to the charger to drop, charger will go into VINDPM and charge current will be decreased. However, with the 5V-3A dedicated adapter, 1A of charge current is possible. But it may also fail to provide 1A of charge current if the adapter cable resistance is high. In both of these cases, the charge status register will show VINDPM active. But your register map does not show that. That is why I suspect that your register map may be not be captured during the issue.

    Best Regards,

    Munir

  • Hello, it was taken when there was a battery actively charging while being pluged on my computer.

    I agree that on my computer i can't get the 1A at 12V, but I should still be able to achieve 500mA at 12V but I can't. 

    The problem is that I can't seem to be able to change anything on this register, the value just never changes, but i can change the other registers.

  • I never tried lowering the value on the 0x02 charging register but I can't seem to change any value in anyone of the 2 charging register(0x02 and 0x03), the charge current just never goes higher than 180mA, and when it's at 180 mA I can't lower it.

    But at least it goes down automatically when the battery is nearing the end of its charge

  • Okay I don't really know how but I finally managed to change the charge current, and at this point i got 680mA/12V out of my Computer

  • Hi Noe,

    Glad to hear you could get more current from the port. Sometimes, a USB-C port behaves differently from a typical power supply. It may limit the inrush current and stop the charger due to its limited capability. 

    Regards,

    Tiger