This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS6594-Q1: TPS6594-Q1 not operation.

Part Number: TPS6594-Q1

Tool/software:

Dear sir,

We are currently reviewing TPS6594133A.

Power was applied to the VCCA and the Enable High signal was entered.

VOUT_LDOVINT, VOUT_LDOVRTC has a 1.8 V output.

However, there is no other BUCK output voltage.

However, when the initial power is applied, the output comes out and stops as shown below.
(GPIO_9, VOUT_LDO3, BUCK4)


Please check this issue.

  • Hello Kyungkeun,

    An error has occurred during the power up and has sent the unit into shutdown, the device then performs a recovery attempt, it repeats (since the problem is still there) until the recovery counter exceeds the limit of 15 attempts. After 15 attempts the device needs to be power cycled to remove the safety lock.

    While the device is powered can you provide the registers 0x5A to 0x6C on base address 0x48?

    These are the interrupt registers that will give more insight as to the error showing up.

    Thank you for the scope shots as this tells me you're able to get roughly through half of the power up sequence:

    Can you step through the power resources below and at which point does the device stop the sequence?

    Best Regards,

    Nicholas

  • Hi Nicholas,

    I've got feedback separately that PMIC (TPS6594133A-Q) is working after adding output capacitor values higher than 47uF. 

    I'll close the e2e.

    Thank you,

    Lloyd

  • which rail have you applied capacitor values higher than 47uF? Could you share since we have similar case.