This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

UCD9224EVM and startup problem of the Fusion Design GUI

Other Parts Discussed in Thread: UCD9224EVM-464, UCD9224

Hi,

I'm testing the Eval-Board UCD9224EVM-464 and I have a problem to startup the Fusion Design GUI.

At the beginning it worked fine. I connected the Eval-Board to my PC with the USB Interface Adapter and made some configurations and read out the status. But through a wrong configuration at the Eval-board or something like that, the Fusion Design GUI don't startup.

I'm getting this alert:

The second part in German means: Target of an invocation that caused an exception.

The I²C connection seems to be OK. The lost or damaged configuration in this Power-controller produced this alert in some way. The Fusion Design Program closes after that alert. I'm getting the same result with an other PC with an other OS.

Is there any possibility to program the UCD9224 by an other program than Fusion Design,

or any other possibility to get the start configuration again?

Greetings,

Dominik

  • Can you try the following procedure and report back any responses.

    1. Close any open instances of the Fusion Digital Power Designer
    2. Connect the USB-to-GPIO adapter to the UCD9224EVM board and apply its input voltage.
    3. Navigate to Start --> All Programs --> Fusion Digital Power Designer --> Device GUIs --> UCD3000 Device GUI  (it may also appear as UCD3xxx Device GUI depending on GUI version).
    4. Under the Tools section of the GUI, click on Device ID to discover the controller and observe response.
    5. If the controller is found then you can stop here but if it isn't discovered then click on Scan for UCD3000 IC in ROM Mode and observe response.

    Let me know what the GUI returns and we can work from there.

     

  • I got the following information:

  • This indicates that the firmware is intact which is what I expected, but wanted to be sure.

    I don't know of any configuration settings that would cause the issues that you are experiencing but since the FW looks good and the problem occurs across multiple host platforms then let's try reloading the configuration that shipped with the EVM.

    Connect the USB Interface Adapter to the EVM and the host computer then power the EVM, make sure the green LED on the adapter is on, indicating that it is connected to the computer.

    Download the configuration file that is attached to this post.

    Open the Firmware and Project File Download Tool by navigating to Start --> All Programs --> Texas Instruments Fusion Digital Power Designer --> Tools --> Firmware & Project File Download Tool

    Which opens the following window

    Leave the Firmware File selection blank, click the UCD3xxx/UCD92xx/UCD90xxx for IC Family and check the Ignore write back mismatch warnings and the Force write of all parameters checkboxes.

    Skip the Firmware Download section of Devices to Program  but click the Project File radio button under Configuration Download Mode then enter 104 for the Addr and enter the location where you stored the configuration file by clicking the Select FIle button.

    Click the Start button.

    Let me know if this works or if you get any other warnings/errors.

     

    http://e2e.ti.com/cfs-file.ashx/__key/communityserver-discussions-components-files/184/4426.HPA464_5F00_EVM_5F00_Default_5F00_Configuration.xml

     

  • Thanks, the reprogramming with the Firmware & Project File Download Tool works without any problems. Now, the startup of the Fusion Design GUI works again.

    Greetings,

    Dominik