This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Problem with UCC27532EVM

Other Parts Discussed in Thread: UCC27532EVM-538, UCC27532

I am using UCC27532EVM-538 to drive a SiC MOSFET. There are tow input voltage sources 10 V and 12 V and PWM as high and Low. I did exactly what the data sheet explain. I used 2 different sources, one of them to generate 10 V and the other for 12V. To generate the PWM signals I used many ways(Function Generator, or Microcontroller) to generate 0(LOW)-5 V (HIGH)

The input PWM as the datasheet in page 5, High MIN=2.75, and HIGH MAX=5.5V

I have found that it WORKS only if the High PWM is more than 9 V Please let me know for further information

Please if you face the same problem, advise me what to do

  • Hello Mr. Mhiesan,

    I'm sorry that you are experiencing this problem. We'll route your question to an appropriate engineer to address it.

    Regards,
    Ulrich Goerke
  • Hello Mr. Ulrich Goerke,

     


    A
    fter having  deep understanding for how this circuit works, I realized that there is something wrong with the datasheet and the UCC27532EV. Therefore, I modified the design and now it works as the datasheet. 

  • Hello Haider,

    We regret you have some issues with the UCC27532 EVM regarding the input PWM signal, but I have found what seems to be the issue.

    The input PWM is isolated thru the U1 opto coupler with R1 and R2 as current limiting resistors in the opto diode. The Vf of the diode is 1.5V nominal, and the opto datasheet recommends driving with 6mA. With 6mA current, the R1 and R2 of 620 Ohms, the voltage result is just under 9V. For 3.3V PWM input signal, the R1 and R2 resistors will need to be 150 Ohms each.