This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ27520-G4 / Communication error after programming srec file from bqStudio

Other Parts Discussed in Thread: BQSTUDIO, BQ27520-G4, BQEVSW


My customer has evaluated bq27520-G4 on their test board and communicate from bqStudio and EV2300. And now they are facing abnormal communication error after following procedure.


  • Confirm to communicate normally at default sample
  • Program default srec file that can be download from bq27520-G4 product folder by using bqStudio
  • After programming, bqStudio can't see bq25720-G4 and so can't read/write any register
  • This no communication error can not be fixed by removing battery


  • Have you had experience such communication error?
  • Do you have any method to communication with such device? I mean that can I access with maskROM mode?

Please let me communicate at off line to provide detailed customer's information if you need.

Best Regards,

Sonoki / Japan Disty

  • Hello Sonoki-san,

    How did you obtain the .srec file? I just programmed an EVM with the firmware from the product folder 

    I used EVSW to program the EVM because my copy of bqStudio doesn't support .senc files. After programming the EVM it enumerates as a bq27520G4 in bqStudio without any problems.

    Can you read from device address 0x16? If so, the gauge is in ROM mode and you can re-try programming the firmware using EVSW. If it doesn't respond to either 0x16 or 0xaa then it may be difficult or impossible to recover.


  • Hi Dominik,

    Thank you for your advice, but I can't find how to change the device address setting on bqStudio. Can you tell me how to change it? It's appreciated if you capture it's screen shot.

    Best Regards,


  • Hi Dominik,

    And regarding how to obtain the .srec file, I performed the same way with you. I imported .senc file by using bqEVSW and export F/W as .srec file. And then import the .srec file by using bqStudio.
    I could not see any problem at EVM, but no communication error can be seen at customer board. So I'm asking you have the same experience at other customers.
    It's appreciated if you ask it in your team.

    Best Regards,
  • Hi Dominik,

    Today I had additional update. I got customer's srec and tried to program it to EVM, then the icons of DashBoard in bqStudio was grayed out and I could't communicate. After that I tried to communicate by using bqEVSW. I couldn't read the register with I2C device address 0xAA but I could read with I2C device address 0x16. Thus I think this srec file has any error.
    So can you please check if the srec file has any error? I'd like to send it directly, so can you contact my email address?

    Best Regards,
  • Sonoki-san,

    I contacted you directly.