This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS65917EVM: The GUI don't access by I2C communication

Part Number: TPS65917EVM

Hi teams,

I am checking the operation using TPS 65917 EVM, and I am worrying that the GUI does not work well in it.

As contents, error code 1026 appears, LabView becomes "VI reference is invalid.", I2C communication can not be performed.
The setting of the jumper pin is set as described in the user guide.
Please let me know if you have any solutions.

Best regards.


  • Hello Hayashi,

    Sorry for the trouble you are experiencing. I haven't seen this error before. Please make sure you are using the latest version on

    Please also try uninstalling the GUI and re-installing it, in case there was some issue with installation.

    If you are still having errors after re-installing, could you let me know when exactly the error shows up - for example immediately after launching, or only when you try an I2C read?

  • Hello Karl,

    It was useless,I tried to uninstall and re-install it.
    I thought that the version of LVRTE was not conforming, so I installed the 32 bit version of 2014 but it did not work.
    I will attach the error window that appeared at that time.
    Please let me know if you have any hints.

    error window.pdf

  • Hello,

    I can see this error when I change the "Page List.ini" file contents in the install directory.  Can you check that you have the below section in your file?  Specifically, if the location is not correct, it will have this error.

    [I2C Control]
    Caption = "I2C Communication"
    Location = "Pages\Register Map Tree\"
    VI Available = "True"

    I've also attached my version of the file here which works for me without errors.  You can copy this in to your install directory to see if it solves the issue.

    Page List.ini

  • Hello,
    As I told you immediately, I fixed the .ini file, but it was not improved.
    In my case, especially "Page List.ini" seems not to be doing bad things.
    I tried using my PC's as well as my colleague's PC, but I got the same result.
    If there are other ideas, please contact us.

    Best regards.