This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LM4132: VREF is not correct

Part Number: LM4132


My customer using LM4132-1.8V.

VIN is ST MCU's GPIO(SENSING_VDD_CTRL) and this GPIO current spec is below and total current consumption is about 180uA.

VREF is for ST MCU's ADC reference.

1) No Yellow Resistor, Disable ADC : VREF voltage is 1.8V, OK

2) No Yellow Resistor, Enable ADC : VREF voltage is about 2.4V, it is not correct.

3) Yellow Resistor (670 ~ 6.2KOhm), Enable ADC ; VREF voltage is 1.8V, OK.

Why this situation is occurred?

Why VREF is not correct in 2) case?

Why VREF is correct in 3) case?

Please let me know.

  • Hi SS Jung,

    This is interesting because the LM4132 acts like an LDO so I am surprised you are getting a higher voltage than what it is rated for. I currently do not have the answers but can you help me by giving me more information.
    Can you give us more information on which ST MCU device this is?
    Is VDDA/VREF+ on the MCU also used as an output?
    Have you tried changing using a different LM4132?
    Is there voltage coming from VSEN_OFFSET?

  • Hi Marcoo

    First of all, I answer to your question.

    1. I will attached more detail schematic.

    2. VDDA/VREF+ is for internal ADC's reference voltage and analog voltage.

    3. We tried another LM4132 and same symptom.

    4. VSEN_OFFSET is using for OPAMP input and this voltage is divided from LM4132's VREF output. No voltage coming from VSEN_OFFSET. And if R18 is not inserted, abnormal output is still occurred.

    I describe detail below.

    [Normal Condition]

    1. Normal MCU_VDD : 3.6V

    2. ST MCU : STM32L443RCT6

    3. LM4132 EN Pin (SENSING_VDD_CTRL) : High

    4. VREF_1V8V : need to 1.8V for ST MCU ADC Reference voltage and ST MCU Analog power

    5. The presence or absence of R18 is irrelevant.


    Test1) MCU_VDD (3.6V), No R44 : We Need  this setting

    Result1> ST MCU's ADC disable ==> VREF_1V8V is 1.8V 

    Result2> ST MCU's ADC enable ==> VREF_1V8V is about 2.45V   ""Abnormal Output""

    Test2) MCU_VDD (3.6V), R44(about 670~6.2KOhm)

    Result> ST MCU's ADC disable or enable ==> VREF_1V8V is 1.8V

    Test3) MCU_VDD (Various voltage), No R44

    Result1> MCU_VDD (under 2.8V), ST MCU's ADC disable or enable ==> VREF_1V8V is 1.8V

    Result2> MCU_VDD (2.8V~3.6V), ST MCU's ADC disable ==> VREF_1V8V is 1.8V 

    Result3> MCU_VDD (2.8V~3.6V), ST MCU's ADC enable ==> VREF_1V8V is about 1.9V~2.45V according to VIN Voltage(MCU_VDD)  ""Abnormal Output""

    **** Please refer these test results and let me know why this issue occurred ****


  • Hi Marcoo
    Thanks for your help.
    I re-checked VREF_1V8 and I found some voltage is come from it.
    So I will check the MCU side.

    Thank you.
  • Hi SS Jung,

    Keep us updated with the results. I am curious on what is causing this. Sometimes these MCU's use the VREF+ pin as an external voltage reference and therefore you would have 2 outputs conflicting with each other.

    -Marcoo Z

  • Hi Marcoo Z,

    I think MCU's setting is internal VREF enable, so VDDA/VREF is working as output pin.

    Customer understand this issue is cause by MCU setting.

    They are going to debug with MCU SW team.

    Thanks for your reply and help.