This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

UCD3138CC64EVM-030: UCD3138EVM and startup problem of Fusion Digital Power Studio

Part Number: UCD3138CC64EVM-030
Other Parts Discussed in Thread: UCD3138PSFBEVM-027, UCD3138


I'm testing the Eval-Board UCD3138CC64EVM-030 together with UCD3138PSFBEVM-027,  and I had a problem to startup the Fusion Digital Power Studio(GUI).

At the beginning it worked fine. However, for the second time, the GUI failed to connect the EVM-Board, and  this alert appeared, where the second part in Chinese means: Target of an invocation that caused an exception.

I found this problem was solved in the post "UCD9224EVM and startup problem of the Fusion Design GUI" (

But I tried to do as showed in the post, and it did not work.

I got the following information:

When using the Firmware & configuration  Download Tool, the following error appeared.  Is the the configuration file not fit for the UCD3138? or any other problems?

Please help me with some advice, thanks!



  • Hello,

    From the first screen, that fact that you can find it in ROM mode means the device is not executing its program flash.  If the device is executing its program flash and the firmware supports device id, as all of our evms do, then you would be able to scan for Device_ID.  Its the first button near Scan for device in program mode that looks cut off in your image "VICE...".

    Maybe you haven't written the checksum in which case the device would reset to ROM mode on a power cycle.  If that's the case you can click "Command ROM to execute Program".  Then do a scan for device id.  If its still in ROM mode then there is some kind of issue with the firmware.


  • Or it may also be that the firmare hasn't been downloaded. Please take a look at this userguide on how to download The relevant section would be 7.3.
  • I would suggest using the device GUI for download instead of the tool you are trying to use.