This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS65086: Output issue of TPS65086401RSKT

Part Number: TPS65086
Other Parts Discussed in Thread: IPG-UI,

Hello team,

One of my Customers is using TPS65086401RSKT in their project. They have given vsys 12V and shorted DRV5V_2_A1     and DRV5V_1_6        with LDO5P0 but not seeing proper output of this device. they have followed below sequence:

  1. CTL1 asserted.
  2. Buck 2 enabled (through I2C register).
  3. Buck 1 enabled after 2ms (through I2C register).
  4. Check the PG of Buck 2 and 1 on GPO1.
  5. Buck 5 enabled (through I2C register).
  6. Check the PG of Buck 2 and 1, and 5 on GPO2.
  7. LDOA2 enabled (through I2C register).
  8. Check the PG of Buck 2 and 1, and 5 and LDOA2 on GPO3.
  9. Buck 6 enabled (through I2C register).
  10. Check the PG of Buck 2 and 1, and 5 and LDOA2 and Buck 6 on GPO4

and measure below voltage on Input pins:

LDO5P0                : 5.027V

VSYS                      : 12.35V

LDO3P3                : 3.299V

VREF                      : 1.249V

DRV5V_2_A1     : 5.027V

DRV5V_1_6        : 5.027V

but getting below output:

BUCK1 : No output

BUCK2 : Output we are getting 0.88V



BUCK5 : No output

BUCK6 : No output

LDOA2 : Output we are getting 1.0V

They have also done below I2C setting:

  1. to set the required VID on all the VRs used (Buck 1, 2, 5 and 6 and LDOA2).
  2. enabled through I2C .
  3. configuring GPIOs for the Power Goods.


 Please help me in resolving their issue..


Vikas Chola

  • Vikas,

    It looks like they are using very different settings than the defaults for the TPS65086401 device. I have a feeling that the settings are not being set correctly, especially because settings like which CTL pins enable which regulators are not accessible through typical means. I would suggest they take a look at the TPS650861, which is the user-programmable version of this device.

    Also, are they able to read all of the register contents of the device? If so can you send that to me? If they are able to connect to the device with the IPG-UI GUI then there there is a "dump registers" option under the report tab that will read the registers and put the results in a txt file.
  • TPS65086401 not reflecting in the IPG-UI GUI.

  • Also, In case of defualt EEPROM setting, when CTL1 asserted,
    BUCK1: No voltage
    BUCK2: 0.88V
    BUCK6: No Voltage

    Why this behaviour ? What could be the reason for No output.?
  • Rajneesh,

    What do you mean by TPS65086401 not reflecting in the IPG-UI GUI? Are the DEVICEID1 and DEVICEID2 registers not matching the expected values? I f you are talking about which device to select when using IPG-UI, you can use the TPS65086-0.7.

    Without being able to read the I2C registers it is hard to say what the issue is. If you can at least read the SHUTDNSRC, PWR_FAULT_STATUS1, and PWR_FAULT_STATUS2 registers, that will tell you if the PMIC is reporting any issues.

    If you are going to enable everything through I2C commands, then I would make sure you follow these steps.
    1. Hold all of the CTL pins low.
    2. Disable each rail you aren't using with their individual disable bits (BUCK1_DIS, etc.).
    3. Set the outputs to their desired voltages.
    4. Set the enable bits in the I2C_RAIL_ENx registers high for each rail you want to control using I2C (BUCK1_EN, etc.) in the order you want to enable them.

    Let me know if this helps.

  • Plz. see above screenshot only these devices are avaialble to select, so suggest which device to select from this list ?

    We tried to read back the register via I2C from our custom code:

    SHUTDNSRC = 06h, then we read PWR_FAULT_STATUS1 Register which came = 20h.

    At this condition outputs are:

    BUCK1= 1.70V
    BUCK2= 0.88V
    BUCK5= 0V
    BUCK6= 1V
    LDOA2= 1.1V

    BUCK6 output in Oscilloscope is as below:

    Yes, we are following these steps:
    1. Hold all of the CTL pins low.
    2. Disable each rail you aren't using with their individual disable bits (BUCK1_DIS, etc.).
    3. Set the outputs to their desired voltages.
    4. Set the enable bits in the I2C_RAIL_ENx registers high for each rail you want to control using I2C (BUCK1_EN, etc.) in the order you want to enable them.

  • Rajneesh,

    I can't see the screenshot you attached, but if you are looking at which device to select in the IPG-UI you should be able to use the TPS65086. If it isn't showing up you can try re-installing the GUI, or you can make sure that the TPS65086-0.7.json file is located in the correct folder. The folder should be something like this C:\Users\[username]\Documents\Texas Instruments\IPG-UI\Devices.

    Link to GUI:

    If you could send me your schematic and layout I would be happy to take a look at it. We at least now know that the cause of the issue is BUCK6 powerfaulting.

    It would also be a good idea to look at a zoomed in scope shot of BUCK 6 with the SW node right before it turns off. Something around the 50uS/div would be good.
  • Hi Nick,

    TPS65086 not available under the device list of IPG-UI. TPS650860-1.1 is there, but read error if I chose this device name.

    This folder is empty (there are no files) C:\Users\USER11\Documents\Texas Instruments\IPG-UI\Devices. I tried reinstalling the IPG-UI also, but still that folder is empty.

    1) At 50uS/div:


    2) At 20mS/div:

    3) At 50mS/div:

  • Rajneesh,

    I just sent Vikas an email with some feedback on your schematic as well as a document to help calculate component values for BUCKs 1, 2, and 6. Without knowing all of your design requirements I can't recommend exact values, but it looks like your BUCK6 output inductance is too high, and output capacitance is too low.

    Please re-evaluate, make changes as needed, and let me know if this helps.
  • Hi Nick,

    Thanks, I tried to change the values as per the calulator shared. Now outputs are there for all desired chanels, but outputs are not correct. Plz. see below readings & graphs.

    Now the register read values are:

    SHUTDNSRC = 04h, then we read PWR_FAULT_STATUS1 Register which came = 00h.

    LDO5P0                : 5.009V
    VSYS                      : 12.20V
    LDO3P3                : 3.304V
    VREF                     : 1.249V
    DRV5V_2_A1       : 5.009V
    DRV5V_1_6         : 5.009V

    At this condition outputs are:

    BUCK1= 1.869V [Against 1.80V]
    BUCK2= 0.865V [Against 0.85V]
    BUCK5= 1.212V [Against 1.20V]
    BUCK6= 0.417V [Against 1.20V]
    LDOA2= 0.850V [Against 0.85V]






  • Rajneesh,

    Can you try reading the BUCK6VID and BUCK6SLPVID registers? If these are not both set to "A0" can you set them to that?
  • Hi Nick,

    I tried to read and values are :

    BUCK6VID = A0

    This is very strange, BUCK6 output is = 0.417V [Against 1.20V]. Registor values are correct, What could be the other reason.
  • Rajneesh,

    This is strange. What values did you end up setting the output capacitance, output inductance, and current limit resistor to?

    Could you send me your layout and show me where exactly you are measuring the voltage?
  • Hi Nick,

    The values used are below for BUCK6:

    Output Inductor (L4) = 800nH

    Output Capacitors: C56=100uF; C769=47uF; C53=10uF; C50=10uF; C768=2.2uF; C765=1uF

    RIMIL6 (R95) = 3.9K

    Below is the layout, I am measuring the Voltage at output of Inductor L4:

  • Rajneesh,

    I don't see any issue with your layout.

    Can you try replacing the PMIC? I am wondering if maybe there was an ESD event that damaged the device.
  • Hi Nick,

    Yes, your doubt was right. I replaced the PMIC with new one. And now outputs are on all required chanels.

    BUCK1 : 1.8V
    BUCK2 : 0.86V
    BUCK5 : 1.2V
    BUCK6 : 1.2V
    LDOA2 : 0.85V

    But output of BUCK1, BUCK5, and BUCK6 are not pure DC, Plz. see below oscilloscope screen capture, there is some dip/pulse is observed. What could be the reason for this:






  • Rajneesh,

    I am glad that fixed your issue.

    The ripple you are seeing on the output is because the regulators are in auto mode instead of forced PWM mode. In auto mode the regulators will switch from pulse width modulation (PWM) mode to pulse frequency modulation (PFM) mode at light loads. This results in a much higher efficiency at light loads, at the cost of increased ripple and decreased transient performance.

    If you want to switch these to forced PWM mode this can be done using the BUCKx_MODE bits in the BUCK123CTRL and BUCK6CTRL registers.
  • Hi Nick,

    The oscilloscope screen which I shared earlier were captured at NO Load condition. And you are right that it was due to auto mode of regulators.

    When I connected the load (External Resistive load). Below are the observations:

    BUCK1 : 1.8V [Dropped to 0V If I connect load]
    BUCK2 : 0.86V [Dropped to 0V If I connect load]
    BUCK5 : 1.2V [OK, and Constant pure DC]
    BUCK6 : 1.2V [Dropped to 0V If I connect load]
    LDOA2 : 0.85V [Dropped to 0V If I connect load, It may be as it is fed thorough BUCK6]

    Plz. suggest what could be the reason for voltage drop after connecting load at BUCK1, BUCK2, & BUCK6

  • Rajneesh,

    What value resistors were you attaching to each of these rails? I wonder if this may be pulling too much current, and is causing the device to powerfault. Alternatively, it might also be the input is pulling too much current and is causing the input voltage to drop.

    Can you read the SHUTDNSRC register and PWR_FAULT_STATUS registers to see what the PMIC is reporting?
  • Hi Nick,

    12V inputs to BUCKs are through a series resistor in schematic/circuit, and I found that these resistance were not 0Ohm. This was error from asembly. So 12V was dropping even at very low load. After changing those to 0 Ohm, problem is resolved.

    All voltages are now perfectly fine at load condition also.

    I sincerely thanks for your valuable support. You can close this thread/post now.

    Have a nice weekend !