This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TPS2373: TPS2373+UCC2897A design issue

Part Number: TPS2373
Other Parts Discussed in Thread: UCC2897A, TPS23881, UCC2897

Hi :

I already follow "www.ti.com/.../PMP21103" design product(poe splitter).

  • IC:TPS2373+UCC2897A)
  • Isolation mode/Class8/ DC 12V output

And our Taiwan TI agent "ARROW" FAE already review circuit OK.
After Sample Run. Poe splitter function not correct.

Although I have provided to ARROW's FAE debug, But I still hope to understand
and expedite the resolution this problem.

Product status

1. If use PSE input (please see the circuit 02) VPP have 48V voltage.
    But Vcout only have a few pulse voltage(very low). And LD1(TPL/TPH)always blinking.

2. 12V DC no any output voltage
     (Give up PSE input) I try to use power supply provide DC power(please see circuit 04 & 05).

  • point 01=DC 48V
  • point 02=DC 12V

But still no any output voltage.

Could you please assist review the circuit?
Please see the below.

Thanks!

Caspar

  • Hello Caspar,

    What kind of PSE are you using?

    Also, is there any load on the system?

    Are you able to show a scope shot of the VCOUT, Vout and gate waveform of Q9?

    If this post answers your question, please indicate so by marking this thread as resolved. Thank you.

     

    Regards, 

     

    Michael P.

    Applications Engineer

    Texas Instruments 

  • Hi Michael:

    • PSE: TPS23881 EVB(please see picture below)
    • Only this product circuit. no add any other loading 

    About VCOUT/TPH/TPL/Q9 Gate waveform.
    Please see the below

    measure point

    • VCOUT=>LD1 pin1
    • TPH=>R15 to U1 pin 18
    • TPL=>R16 to U1 pin 17
    • Q9 Gate=>U2 pin 12

    Caspar

    VCOUT/TPH/TPL

    Q9 gate

  • Hello,

    Please try adding some load, like 10ohms, thank you.

    If this post answers your question, please indicate so by marking this thread as resolved. Thank you.

     

    Regards, 

     

    Michael P.

    Applications Engineer

    Texas Instruments 

  • Hi Michael:

    Sorry I'm not so sure about that.
    If you mean 12V output point add load.(Please see the picture below)
    I already try to use "DC Electronic Load"add 1A load.
    But still keep the same status.(LED blinking and no 12V output etc)

    If I misunderstand you mean, please describe detail location again.

    Thanks!

    Caspar

  • Hello Casper, 

    Can you try powering the board with a DC power supplies across C27? 

    That way we can understand if the DC-DC is working properly, so we can determine if the source of the problem is there, or in PoE portion. 

    Also, are you able to show the output capacitance values?

    Lastly, the PSE you are using should have software that can indicate a valid detection. Does it show the MPS current?

    If this post answers your question, please indicate so by marking this thread as resolved. Thank you.

     

    Regards, 

     

    Michael P.

    Applications Engineer

    Texas Instruments 

  • Hi Michael:

    About UCC2897 circuit issue. Our agent's FAE found the D22 component was wrong.
    If D22 Change to TL431AIDBZR. The UCC2897 circuit can operate correctly
    (In the U1(TPS23881)/L3 removed and use external DC provide 48V/12V voltage state).

    But Now I don't have this component(TL431AIDBZR).I already apply for "TL431AIDBZR" sample.
    Because I still hope duplicate this status by myself to ensure that replacement can solve the UCC2897 output problem.


    Please temporarily focus on TPS23881 LED problem.
    I already remove L3 & U22(UCC2897) and use TPS23881 GUI catch the picture.
    Please see the below.
    About LED issue. Could you have any suggest?

    Caspar

  • Hello,

    If D22 is wrong, this behavior makes sense. This is the voltage lock circuit for the feedback network. If this is set incorrectly, it will either signal the output is railing high or shutting down, so the controller is reacting to that. I think the best course of action is to wait for the samples. Let me know how it goes.

    If this post answers your question, please indicate so by marking this thread as resolved. Thank you.

     

    Regards, 

     

    Michael P.

    Applications Engineer

    Texas Instruments 

  • Hi Michael:

    Thanks! Update product status. Our agent's FAE already solved DC output issue.
    12V voltage output is correct(Use POE-PSE input).But output power less than 40W. Agent's FAE still adjusted.


    Please assist keep focus on TPS23881 LED problem.
    Please see the below.I already catch VCOUT signal.
    VCOUT Voltage is not stable(Max=14.8V Min=6.4V).
    LED always blinking

    About LED issue. Could you have any suggest?

    Thanks!

    Caspar

  • Hi Michael:

    About LED always blinking issue.

    Could you have any suggest?

    Thanks!

    Caspar

  • Hello Casper, 

    I would suggest creating a new post for the TPS23881, as I am not as familiar with this part. 

    I know the EVM has an LED at the input, and if it is blinking it sounds like it could be loosing power. But again I would create a new thread. thanks!

    If this post answers your question, please indicate so by marking this thread as resolved. Thank you.

     

    Regards, 

     

    Michael P.

    Applications Engineer

    Texas Instruments 

  • Dear Michael:


    Thanks for your support. I already recreate another question.


    Caspar